devclass_get_softc man page on FreeBSD

Printed from http://www.polarhome.com/service/man/?qf=devclass_get_softc&af=0&tf=2&of=FreeBSD

DEVCLASS_GET_SOFTC(9)	 BSD Kernel Developer's Manual	 DEVCLASS_GET_SOFTC(9)

NAME
     devclass_get_softc — translate unit number to driver private structure

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void *
     devclass_get_softc(devclass_t dc, int unit);

DESCRIPTION
     This function retrieves the driver private instance variables for the
     device with the given unit number and returns it.

RETURN VALUES
     If the device exists, its driver-private variables are returned, other‐
     wise NULL is returned.

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net