device_add_child_ordered man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

DEVICE_ADD_CHILD(9)	 BSD Kernel Developer's Manual	   DEVICE_ADD_CHILD(9)

NAME
     device_add_child, device_add_child_ordered — add a new device as a child
     of an existing device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     device_t
     device_add_child(device_t dev, const char *name, int unit);

     device_t
     device_add_child_ordered(device_t dev, int order, const char *name,
	 int unit);

DESCRIPTION
     Create a new child device of dev.	The name and unit arguments specify
     the name and unit number of the device.  If the name is unknown then the
     caller should pass NULL.  If the unit is unknown then the caller should
     pass -1 and the system will choose the next available unit number.

     The name of the device is used to determine which drivers might be appro‐
     priate for the device.  If a name is specified then only drivers of that
     name are probed.  If no name is given then all drivers for the owning bus
     are probed.

     This allows busses which can uniquely identify device instances (such as
     PCI) to allow each driver to check each device instance for a match.  For
     busses which rely on supplied probe hints where only one driver can have
     a chance of probing the device, the driver name should be specified as
     the device name.

     Normally unit numbers will be chosen automatically by the system and a
     unit number of -1 should be given.	 When a specific unit number is
     desired (e.g. for wiring a particular piece of hardware to a pre-config‐
     ured unit number), that unit should be passed.  If the specified unit
     number is already allocated, a new unit will be allocated and a diagnos‐
     tic message printed.

     If the devices attached to a bus must be probed in a specific order (e.g.
     for the ISA bus some devices are sensitive to failed probe attempts of
     unrelated drivers and therefore must be probed first), the order argument
     of device_add_child_ordered(9) should be used to specify a partial order‐
     ing.  The new device will be added before any existing device with a
     greater order.  If device_add_child(9) is used, then the new child will
     be added as if its order was zero.

RETURN VALUES
     The new device if successful, NULL otherwise.

SEE ALSO
     BUS_ADD_CHILD(9), device(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net