device_disable man page on GhostBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
GhostBSD logo
[printable version]

DEVICE_ENABLE(9)	 BSD Kernel Developer's Manual	      DEVICE_ENABLE(9)

NAME
     device_enable, device_disable, device_is_enabled — manipulate device
     enabled flag

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     device_enable(device_t dev);

     void
     device_disable(device_t dev);

     int
     device_is_enabled(device_t dev);

DESCRIPTION
     Each device has an enabled flag associated with it.  A device is enabled
     by default when it is created but may be disabled (for instance to pre‐
     vent a destructive or time consuming probe attempt).  To disable a
     device, call device_disable(), to re-enable it, call device_enable() and
     to test to see if a device is enabled, call device_is_enabled().

SEE ALSO
     device(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for GhostBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net