dir man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

DIR(5)			    BSD File Formats Manual			DIR(5)

NAME
     dir, dirent — directory file format

SYNOPSIS
     #include <dirent.h>

DESCRIPTION
     Directories provide a convenient hierarchical method of grouping files
     while obscuring the underlying details of the storage medium.  A direc‐
     tory file is differentiated from a plain file by a flag in its inode(5)
     entry.  It consists of records (directory entries) each of which contains
     information about a file and a pointer to the file itself.	 Directory
     entries may contain other directories as well as plain files; such nested
     directories are referred to as subdirectories.  A hierarchy of directo‐
     ries and files is formed in this manner and is called a file system (or
     referred to as a file system tree).

     Each directory file contains two special directory entries; one is a
     pointer to the directory itself called dot ‘.’ and the other a pointer to
     its parent directory called dot-dot ‘..’.	Dot and dot-dot are valid
     pathnames, however, the system root directory ‘/’, has no parent and dot-
     dot points to itself like dot.

     File system nodes are ordinary directory files on which has been grafted
     a file system object, such as a physical disk or a partitioned area of
     such a disk.  (See mount(2) and mount(8).)

     The directory entry format is defined in <sys/dirent.h>.  This file
     should not be included directly by applications.

SEE ALSO
     fs(5), inode(5)

HISTORY
     A dir file format appeared in Version 7 AT&T UNIX.

BUGS
     The usage of the member d_type of struct dirent is unportable as it is
     DragonFly/FreeBSD-specific.  It also may fail on certain filesystems, for
     example the cd9660 filesystem.

BSD				 March 5, 2005				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net