disktab man page on OpenBSD

Man page or keyword search:  
man Server   11362 pages
apropos Keyword Search (all sections)
Output format
OpenBSD logo
[printable version]

DISKTAB(5)		  OpenBSD Programmer's Manual		    DISKTAB(5)

NAME
     disktab - disk description file

SYNOPSIS
     #include <disktab.h>

DESCRIPTION
     disktab is a simple database which describes disk geometries and disk
     partition characteristics.	 It is used to initialize the disk label on
     the disk.	The format is patterned after the termcap(5) terminal
     database.	Entries in disktab consist of a number of colon (`:')
     separated fields.	The first entry for each disk gives the names which
     are known for the disk, separated by ``|'' characters.  The last name
     given should be a long name fully identifying the disk.

     The following list indicates the normal values stored for each disk
     entry:

     Name      Type	Description
     ty	       str	Type of disk (e.g., removable, winchester).
     dt	       str	Type of controller (e.g., SMD, ESDI, floppy).
     ns	       num	Number of sectors per track.
     nt	       num	Number of tracks per cylinder.
     nc	       num	Total number of cylinders on the disk.
     sc	       num	Number of sectors per cylinder (default: ns*nt).
     su	       num	Number of sectors per unit (default: sc*nc).
     se	       num	Sector size in bytes (default: DEV_BSIZE).
     sf	       bool	Controller supports bad144-style bad sector
			forwarding.
     rm	       num	Rotation speed in RPM (default: 3600).
     sk	       num	Sector skew per track (default: 0).
     cs	       num	Sector skew per cylinder (default: 0).
     hs	       num	Headswitch time in usec (default: 0).
     ts	       num	One-cylinder seek time in usec (default: 0).
     il	       num	Sector interleave (n:1) (default: 1).
     d[0-4]    num	Drive-type-dependent parameters.
     b0	       str	Pathname to primary bootstrap.
     b1	       str	Pathname to secondary bootstrap.
     bs	       num	Boot block size (default: BBSIZE).
     sb	       num	Superblock size (default:  SBSIZE).

     ba	       num	Block size for partition ``a'' (bytes).
     bd	       num	Block size for partition ``d'' (bytes).
     be	       num	Block size for partition ``e'' (bytes).
     [...]
     bp	       num	Block size for partition ``p'' (bytes).

     fa	       num	Fragment size for partition ``a'' (bytes).
     fd	       num	Fragment size for partition ``d'' (bytes).
     fe	       num	Fragment size for partition ``e'' (bytes).
     [...]
     fp	       num	Fragment size for partition ``p'' (bytes).

     oa	       num	Offset of partition ``a'' (sectors).
     ob	       num	Offset of partition ``b'' (sectors).
     oc	       num	Offset of partition ``c'' (sectors).
     [...]
     op	       num	Offset of partition ``p'' (sectors).

     pa	       num	Size of partition ``a'' (sectors).
     pb	       num	Size of partition ``b'' (sectors).
     pc	       num	Size of partition ``c'' (sectors).
     [...]
     pp	       num	Size of partition ``p'' (sectors).

     ta	       str	Type of partition ``a'' (4.2BSD, swap, etc.).
     tb	       str	Type of partition ``b''.
     tc	       str	Type of partition ``c''.
     [...]
     tp	       str	Type of partition ``p''.

FILES
     /etc/disktab

SEE ALSO
     getdiskbyname(3), disklabel(5), disklabel(8), newfs(8)

HISTORY
     The disktab description file appeared in 4.2BSD.

OpenBSD 4.9			 May 31, 2007			   OpenBSD 4.9
[top]

List of man pages available for OpenBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net