DUMPFS(8) BSD System Manager's Manual DUMPFS(8)NAMEdumpfs — dump file system information
SYNOPSISdumpfs [-f] [-m] filesys | device
The dumpfs utility prints out the super block and cylinder group informa‐
tion for the file system or special device specified, unless the -f or -m
flag is specified. The listing is very long and detailed. This command
is useful mostly for finding out certain file system information such as
the file system block size and minimum free space percentage.
If -f is specified, a sorted list of all free fragments and free fragment
ranges, as represented in cylinder group block free lists, is printed.
If the flag is specified twice, contiguous free fragments are not col‐
lapsed into ranges and instead printed in a simple list. Fragment num‐
bers may be converted to raw byte offsets by multiplying by the fragment
size, which may be useful when recovering deleted data.
If -m is specified, a newfs(8) command is printed that can be used to
generate a new file system with equivalent settings.
SEE ALSOdisktab(5), fs(5), disklabel(8), fsck(8), newfs(8), tunefs(8)HISTORY
The dumpfs utility appeared in 4.2BSD.
BSD January 28, 2009 BSD