dumpsys man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CPU_DUMPCONF(9)		 BSD Kernel Developer's Manual	       CPU_DUMPCONF(9)

NAME
     cpu_dumpconf, cpu_dump, cpu_dumpsize, dumpsys — machine-dependent kernel
     core dumps

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     void
     cpu_dumpconf(void);

     int
     cpu_dump(int (*dump)(dev_t, daddr_t, void *, size_t), daddr_t *blknop);

     int
     cpu_dumpsize(void);

     void
     dumpsys(void);

DESCRIPTION
     cpu_dumpconf() is the machine-dependent interface invoked during system
     bootstrap to determine the dump device and initialize machine-dependent
     kernel core dump state.  Internally, cpu_dumpconf() will invoke
     cpu_dumpsize() to calculate the size of machine-dependent kernel core
     dump headers.

     dumpsys() is invoked by cpu_reboot() to dump kernel physical memory onto
     the dump device.  dumpsys() invokes cpu_dump() to write the machine-
     dependent header to the dump device at block number *blknop using the
     dump device's PIO dump routine specified by the dump argument.

     cpu_dumpsize(), cpu_dump(), and dumpsys() are parts of the machine-depen‐
     dent interface, however they are not exported to machine-independent
     code.

SEE ALSO
     cpu_reboot(9)

BSD				 May 24, 2002				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net