EHCI(4) BSD Kernel Interfaces Manual EHCI(4)NAMEehci — USB Enhanced Host Controller driver
The ehci driver provides support for the USB Enhanced Host Controller
Interface, which is used by USB 2.0 controllers.
EHCI controllers are peculiar in that they can only handle the USB 2.0
protocol. This means that they normally have one or more companion con‐
trollers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Conse‐
quently each USB connector is electrically connected to two USB con‐
trollers. The handling of this is totally automatic, but can be noticed
since USB 1.x and USB 2.0 devices plugged in to the same connector appear
to connect to different USB busses.
SEE ALSOohci(4), uhci(4), usb(4)HISTORY
The ehci device driver first appeared in FreeBSD 5.1.
The driver is not finished and is quite buggy.
There is currently no support for isochronous transfers.
BSD March 20, 2005 BSD