enable_idds(5)enable_idds(5)NAMEenable_idds - enable intrusion detection data source
if HP-UX HIDS is installed,
From HP-UX 11i Version 3 onwards, the tunable is replaced by the
dynamic tunable audit_track_paths(5).
If is set to then the HP-UX Host Intrusion Detection System (HP-UX
HIDS) can enable the collection of kernel data for intrusion detection.
This also causes additional things to be tracked by the kernel, result‐
ing in a small degradation in performance (and increase in kernel mem‐
ory usage), even if HP-UX HIDS is not in use.
Who Is Expected to Change This Tunable?
Anyone using HP-UX HIDS.
Restrictions on Changing
Changes to this tunable take effect at the next reboot.
When Should the Tunable Be Turned On?
This tunable should be turned on if HP-UX HIDS is installed. The
installation will automatically turn on
What Are the Side Effects of Turning the Tunable On?
The name of the current working directory (and root directory) of every
process is tracked, resulting in a change in memory usage and perfor‐
mance of the system.
When Should the Tunable Be Turned Off?
If HP-UX HIDS is not being used should be turned off.
What Are the Side Effects of Turning the Tunable Off?
When turned off, HP-UX HIDS is unable to use any detection template
that uses (See the documentation for HP-UX HIDS for more information on
What Other Tunables Should Be Changed at the Same Time?
This tunable is independent of other tunables.
This tunable has been replaced by
All HP-UX kernel tunable parameters are release-specific. This parame‐
ter may be removed or have its meaning changed in future releases of
Installation of optional kernel software, from HP or other vendors, may
cause changes to tunable parameter values. After installation, some
tunable parameters may no longer be at the default or recommended val‐
ues. For information about the effects of installation on tunable val‐
ues, consult the documentation for the kernel software being installed.
For information about optional kernel software that was factory
installed on your system, see at
was developed by HP.
SEE ALSOaudit_track_paths(5), ids.cf(5),
OBSOLETED Tunable Kernel Parameters enable_idds(5)