ether man page on BSDOS

Man page or keyword search:  
man Server   6284 pages
apropos Keyword Search (all sections)
Output format
BSDOS logo
[printable version]

ETHER(4)		    BSD Programmer's Manual		      ETHER(4)

NAME
     ether - Ethernet Protocol

SYNOPSIS
     #include <sys/types.h>
     #include <sys/sysctl.h>
     #include <net/if.h>
     #include <netinet/if_ether.h>

DESCRIPTION
     The Ethernet (ether) interface type includes all the device drivers for
     interfaces that implement Ethernet framing on both 10Mb/s and 100Mb/s me-
     dia.

PROTOCOL CONTROL OPERATIONS
     The Ethernet support routines implement the following CTL_LINK_HWTYPE
     sysctls:

     Fourth level name	      Type	 Changeable
     ETHERCTL_MULTIADDRS      struct ether_multi       no

     ETHERCTL_MULTIADDRS
	     Returns a chain of ether_multi structures with the enm_next
	     pointers adjusted for user space.	Each structure describes a
	     range or single multicast address and the number of claims on the
	     multicast address range.

SEE ALSO
     ioctl(2),	socket(2),  sysctl(3),	arp(4),	 inet(4),  intro(4),  ifcon-
     fig(8)

 BSD/OS			       November 14, 1997			     1
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server BSDOS

List of man pages available for BSDOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net