flash man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

FLASH(4)		 BSD Kernel Interfaces Manual		      FLASH(4)

NAME
     flash — device-independent flash layer

SYNOPSIS
     #include <sys/flash.h>

DESCRIPTION
     The flash driver provides a device-independent interface for using flash
     memory.

     The following ioctl(2) operations are supported on /dev/flash:

     FLASH_BLOCK_ISBAD (struct flash_badblock_params)
	     This command checks if a block is marked as bad.

     FLASH_BLOCK_MARKBAD (struct flash_badblock_params)
	     This command marks a block as bad.

     FLASH_DUMP (struct flash_dump_params)
	     This command dumps a block.

     FLASH_ERASE_BLOCK (struct flash_erase_params)
	     This command erases one or more blocks.

     FLASH_GET_INFO (struct flash_info_params)
	     This command aquires information aboout the flash device.

FILES
     /dev/flash

SEE ALSO
     flash(9), nand(9)

AUTHORS
     Adam Hoka ⟨ahoka@NetBSD.org⟩

BSD			       January 21, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net