fs_symlinks(5)fs_symlinks(5)NAMEfs_symlinks - maximum number of symbolic links used to resolve a path
The minimum value allowed is 20. The maximum value allowed is 1024, or
Specify a positive integer value.
The tunable represents the maximum number of symbolic links followed by
the kernel when resolving a path name. Applications that create sym‐
bolic links and/or parse path names should also now use this limit rep‐
resented by to be consistent with the kernel.
Who Is Expected to Change This Tunable?
Anyone expecting to run applications using path names that may expand
to a large number of symbolic links.
Restrictions on Changing
None. The tunable is dynamic (tuning will take effect immediately on
the running system).
When Should the Value of This Tunable Be Raised?
This tunable value should be raised when applications are expected to
create and/or parse path names that may expand to a large number of
What are the Side Effects of Raising the Value?
When Should the Value of This Tunable Be Lowered?
This value rarely needs to be lowered, unless there is a reason to
limit the number of symbolic links in an expanded path name.
What are the Side Effects of Lowering the Value?
The kernel will not be able to resolve path names with more symbolic
links than the limit represented by
What Other Tunable Values Should Be Changed at the Same Time?
All HP-UX kernel tunable parameters are release specific. This parame‐
ter may be removed or have its meaning changed in future releases of
NOTE: The define traditionally defined in is now obsolete and should
not be used. This limit (number of symbolics links that may be
expanded in a path name) is now available to applications via this new
tunable parameter, The interfaces provided by the tunable infrastruc‐
ture should be used to obtain the value of At the application level,
use the gettune(2) or kctune(1M) interface. Applications using the
define may not be consistent with the kernel. The define will be
removed in post-HP-UX 11i Version 2 releases.
Installation of optional kernel software, from HP or other vendors, may
cause changes to tunable parameter values. After installation, some
tunable parameters may no longer be at the default or recommended val‐
ues. For information about the effects of installation on tunable val‐
ues, consult the documentation for the kernel software being installed.
For information about optional kernel software that was factory
installed on your system, see at
was developed by HP.
SEE ALSOkctune(1M), sam(1M), gettune(2), settune(2), ulimit(2), setrlimit(2),
Tunable Kernel Parameters fs_symlinks(5)