fuword man page on OpenDarwin

Man page or keyword search:  
man Server   3202 pages
apropos Keyword Search (all sections)
Output format
OpenDarwin logo
[printable version]

FETCH(9)		 BSD Kernel Developer's Manual		      FETCH(9)

NAME
     fetch, fubyte, fusword, fuswintr, fuword — fetch data from user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>
     #include <sys/resourcevar.h>

     int
     fubyte(const void *base);

     int
     fusword(void *base);

     int
     fuswintr(void *base);

     long
     fuword(const void *base);

DESCRIPTION
     The fetch functions are designed to copy small amounts of data from user-
     space.

     The fetch routines provide the following functionality:

     fubyte()	 Fetches a byte of data from the user-space address base.

     fusword()	 Fetches a short word of data from the user-space address
		 base.

     fuswintr()	 Fetches a short word of data from the user-space address
		 base.	This function is safe to call during an interrupt con‐
		 text.

     fuword()	 Fetches a word of data from the user-space address base.

RETURN VALUES
     The fetch functions return the data fetched or -1 on failure.

SEE ALSO
     copy(9), store(9)

BSD				January 7, 1996				   BSD
[top]

List of man pages available for OpenDarwin

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net