getprpw(1M)getprpw(1M)NAMEgetprpw - display protected password database
displays the user's protected password database settings. This command
is available only to the superuser in a trusted system. Normally it is
only used via SAM, see sam(1M).
uses the configuration file default if is not specified. See nss‐
recognizes the following options.
Specifies to get information from the local user.
Displays the arguments supplied to
in raw format
Displays the database value for the argument passed.
An "invalid-opt" is printed if a list of options passed to con‐
tains an invalid option. The rest of the options will be pro‐
cessed. If is specified without all parameters are displayed in
the order given below.
Boolean values are returned as or (for system default values in
Numeric values are specified as positive numbers, 0, or -1. A
value of -1 indicates that the field has not been assigned a
value in the database.
Units of time are returned in number of days (>=0), although the
database keeps them in seconds. This and other minor differences
between the command parameters and the database fields are con‐
sistent with modprpw(1M).
The following parameters for the user can be displayed using the
They are listed below in the order shown in The database fields
are fully explained in prpwd(4).
boot authorization flag
minimum time between password changes
maximum password length
password expiration time
last successful password change time
last unsuccessful password change time
account expiration time
last login time interval
password expiration warning time
whether user picks password,
whether system generates pronounceable passwords,
whether password is restricted, i.e, checked for triviality,
NULL passwords are allowed,
whether system generates passwords having characters only,
whether system generates passwords having letters only,
time of day allowed for login
time of last successful login
time of last unsuccessful login
tty of last successful login
consecutive number of unsuccessful logins so far
tty of last unsuccessful login
maximum unsuccessful login tries
if on, if off, if not set.
returns the reason for a lockout in a "bit" valued string,
where 0 = condition not present, 1 is present.
The position, left to right represents:
1 past password lifetime
2 past last login time (inactive account)
3 past absolute account lifetime
4 exceeded unsuccessful login attempts
5 password required and a null password
6 admin lock
7 password is a *
1 user not privileged
2 incorrect usage
3 cannot find the password file
4 system is not trusted
Displays the database aging fields for user "someusr".
The command displays:
This command is intended for SAM use only. It may change with each
release and can not be guaranteed to be backward compatible.
Several database fields interact with others. The side effects of an
individual change may not cause a problem till much later.
Special meanings may apply in the following cases:
· an absent field
· a field without a value
· a field with a zero value
HP-UX 11i Version 3 is the last release to support trusted systems
was developed by HP.
System Password file
Protected Password Database
System Defaults Database
SEE ALSOmodprpw(1M), prpwd(4), nsswitch.conf(4).
TO BE OBSOLETED getprpw(1M)