GPIB(4) BSD Kernel Interfaces Manual GPIB(4)NAMEgpib — General-Purpose Instrument Bus (GPIB) driver
Either of the pcii(4) or tnt4882(4) drivers use this driver as the back‐
The gpib driver provides support for driving an IEEE-488 bus, also called
IEC-625 (or just "IEC bus"), or HP-IB (Hewlett Packard Instrument Bus),
or GPIB (General Purpose Instrument Bus). The device can become either a
listener, talker, controller, and in particular a master controller on
/dev/gpibNib Main device node to access the driver.
/dev/gpibNl Listen-only entry to the driver. When opening, an instru‐
ment can send data to this device on the bus in an unad‐
dressed mode, for example hard-copy printer data.
SEE ALSOgpib(3), pcii(4), tnt4882(4)HISTORY
The gpib driver was written by Poul-Henning Kamp, and first appeared in
This manual page was written by Jörg Wunsch.
BSD January 24, 2010 BSD