hash32_buf man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

HASH(9)			 BSD Kernel Developer's Manual		       HASH(9)

NAME
     hash, hash32_buf, hash32_str, hash32_strn — kernel hash functions

SYNOPSIS
     #include <sys/types.h>
     #include <sys/hash.h>

     uint32_t
     hash32_buf(const void *buf, size_t len, uint32_t ihash);

     uint32_t
     hash32_str(const void *buf, uint32_t ihash);

     uint32_t
     hash32_strn(const void *buf, size_t len, uint32_t ihash);

DESCRIPTION
     The hash functions returns a hash of the given buffer.

     The hash32_buf() function returns a 32 bit hash of buf, which is len
     bytes long, seeded with an initial hash of ihash (which is usually
     HASH32_BUF_INIT).	This function may use a different algorithm to
     hash32_str() and hash32_strn().

     The hash32_str() function returns a 32 bit hash of buf, which is a NUL
     terminated ASCII string, seeded with an initial hash of ihash (which is
     usually HASH32_STR_INIT).	This function must use the same algorithm as
     hash32_strn(), so that the same data returns the same hash.

     The hash32_strn() function returns a 32 bit hash of buf, which is a NUL
     terminated ASCII string, up to a maximum of len bytes, seeded with an
     initial hash of ihash (which is usually HASH32_STR_INIT).	This function
     must use the same algorithm as hash32_str(), so that the same data
     returns the same hash.

     The ihash parameter is provided to allow for incremental hashing by
     allowing successive calls to use a previous hash value.

RETURN VALUES
     The hash32_* functions return a 32 bit hash of the provided buffer.

HISTORY
     The kernel hashing API first appeared in NetBSD 1.6.

BSD			       December 5, 2001				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net