HOSTS.EQUIV(5) BSD File Formats Manual HOSTS.EQUIV(5)NAME
hosts.equiv, .rhosts — trusted remote host and user name data base
The hosts.equiv and .rhosts files contain information regarding trusted
hosts and users on the network. For each host a single line should be
present with the following information:
or the more verbose
A “@” indicates a host by netgroup or user by netgroup. A single “+”
matches all hosts or users. A host name with a leading “-” will reject
all matching hosts and all their users. A user name with leading “-”
will reject all matching users from matching hosts.
Items are separated by any number of blanks and/or tab characters. A “#”
indicates the beginning of a comment; characters up to the end of the
line are not interpreted by routines which search the file.
Host names are specified in the conventional Internet DNS dotted-domains
“.” (dot) notation using the inet_addr(3) routine from the Internet
address manipulation library, inet(3). Host names may contain any print‐
able character other than a field delimiter, newline, or comment charac‐
For security reasons, a user's .rhosts file will be ignored if it is not
a regular file, or if it is not owned by the user, or if it is writable
by anyone other than the user.
/etc/hosts.equiv The hosts.equiv file resides in /etc.
$HOME/.rhosts .rhosts file resides in $HOME.
Trust user “foo” from host “bar.com”.
Trust all hosts from netgroup “allclient”.
Trust all hosts from netgroup “allclient” and their users except users
from netgroup “dau”.
SEE ALSOrcp(1), rlogin(1), rsh(1), gethostbyname(3), inet(3), innetgr(3),
ruserok(3), netgroup(5), ifconfig(8), named(8), yp(8)BUGS
This manual page is incomplete. For more information read the source in
src/lib/libc/net/rcmd.c or the SunOS manual page.
BSD December 8, 2007 BSD