HPTMV(4) BSD Kernel Interfaces Manual HPTMV(4)NAMEhptmv — HighPoint RocketRAID 182x device driver
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The hptmv driver provides support for HighPoint's RocketRAID 182x based
These devices support ATA disk drives and provide RAID0 (striping), RAID1
(mirroring), and RAID5 functionality.
The hptmv driver supports the following ATA RAID controllers:
· HighPoint's RocketRAID 182x series
The hptmv driver only works on the i386 and amd64 platforms as it
requires a binary blob object from the manufacturer which they only sup‐
ply for these platforms. The hptmv driver does not work on i386 with
SEE ALSOkld(4), kldload(8), loader(8)HISTORY
The hptmv device driver first appeared in FreeBSD 5.3.
The hptmv device driver was written by HighPoint Technologies, Inc., and
ported to FreeBSD by Scott Long. This manual page was written by David
The hptmv driver does not support manipulating the RAID from the OS,
RAIDs need to be set up from the on-board BIOS.
BSD November 17, 2005 BSD