AN(4) BSD Kernel Interfaces Manual AN(4)NAME
an — Aironet Communications 4500/4800 wireless network adapter driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The an driver provides support for Aironet Communications 4500 and 4800
wireless network adapters and variants, including the following:
· Aironet Communications 4500 and 4800 series
· Cisco Aironet 340 and 350 series
· Xircom Wireless Ethernet Adapter
Support for these devices include the ISA, PCI and PCMCIA varieties. The
Aironet 4500 series adapters operate at 1 and 2Mbps while the Aironet
4800 series and Cisco adapters can operate at 1, 2, 5.5 and 11Mbps. The
ISA, PCI and PCMCIA devices are all based on the same core PCMCIA modules
and all have the same programming interface, however unlike the Lucent
WaveLAN/IEEE cards, the ISA and PCI cards appear to the host as normal
ISA and PCI devices and do not require any PCCARD support.
The PCMCIA Aironet cards require PC Card support, including the kernel
pccard(4) driver. ISA cards can either be configured to use ISA Plug and
Play or to use a particular I/O address and IRQ by properly setting the
DIP switches on the board. (The default switch setting is for Plug and
Play.) The an driver has Plug and Play support and will work in either
configuration, however when using a hard-wired I/O address and IRQ, the
driver configuration and the NIC's switch settings must agree. PCI cards
require no switch settings of any kind and will be automatically probed
All host/device interaction with the Aironet cards is via programmed I/O.
The Aironet devices support 802.11 and 802.3 frames, power management,
BSS (infrastructure) and IBSS (ad-hoc) operation modes. The an driver
encapsulates all IP and ARP traffic as 802.11 frames, however it can
receive either 802.11 or 802.3 frames. Transmit speed is selectable
between 1Mbps, 2Mbps, 5.5Mbps, 11Mbps or "auto" (the NIC automatically
chooses the best speed).
By default, the an driver configures the Aironet card for infrastructure
For more information on configuring this device, see ifconfig(8).
an%d: init failed The Aironet card failed to become ready after an ini‐
tialization command was issued.
an%d: failed to allocate %d bytes on NIC The driver was unable to allo‐
cate memory for transmit frames in the NIC's on-board RAM.
an%d: device timeout The Aironet card failed to generate an interrupt to
acknowledge a transmit command.
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), wlan(4), ancontrol(8),
The an device driver first appeared in FreeBSD 4.0.
The an driver was written by Bill Paul ⟨firstname.lastname@example.org⟩.
BSD July 16, 2005 BSD