LGE(4) BSD Kernel Interfaces Manual LGE(4)NAME
lge — Level 1 LXT1001 NetCellerator PCI Gigabit Ethernet adapter driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The lge driver provides support for various NICs based on the Level 1
LXT1001 NetCellerator Gigabit Ethernet controller chip.
The LXT1001 supports fiber PHYs and also a GMII port for use with
10/100/1000 copper PHYs, however there are currently no NICs on the mar‐
ket that use this feature.
The LXT1001 supports TCP/IP checksum offload for receive and VLAN-based
filtering as well as a 64-bit multicast hash filter. It also supports
jumbo frames, which can be configured via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con‐
figures the adapter to receive and transmit jumbo frames. Using jumbo
frames can greatly improve performance for certain tasks, such as file
transfers and data streaming.
The lge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user
can manually override the autoselected mode by adding media
options to rc.conf(5).
1000baseSX Set 1000baseSX operation over fiber optic cable. Both
full-duplex and half-duplex modes are supported.
The lge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
Adapters supported by the lge driver include:
· SMC TigerCard 1000 (SMC9462SX)
· D-Link DGE-500SX
lge%d: couldn't map memory A fatal initialization error has occurred.
lge%d: couldn't map ports A fatal initialization error has occurred.
lge%d: couldn't map interrupt A fatal initialization error has occurred.
lge%d: no memory for softc struct! The driver failed to allocate memory
for per-device instance information during initialization.
lge%d: failed to enable memory mapping! The driver failed to initialize
PCI shared memory mapping. This might happen if the card is not in a
lge%d: no memory for jumbo buffers! The driver failed to allocate memory
for jumbo frames during initialization.
lge%d: watchdog timeout The device has stopped responding to the net‐
work, or there is a problem with the network connection (cable).
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
Level 1 LXT1001 Programming Manual,
The lge device driver first appeared in FreeBSD 4.4.
The lge driver was written by Bill Paul ⟨firstname.lastname@example.org⟩.
BSD July 16, 2005 BSD