SIS(4) BSD Kernel Interfaces Manual SIS(4)NAME
sis — SiS 900, SiS 7016 and NS DP83815/DP83816 Fast Ethernet device
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The sis driver provides support for PCI Ethernet adapters and embedded
controllers based on the Silicon Integrated Systems SiS 900 and SiS 7016
Fast Ethernet controller chips.
This driver also supports adapters based on the National Semiconductor
DP83815 (MacPhyter) and DP83816 PCI Ethernet controller chip.
The SiS 900 is a 100Mbps Ethernet MAC and MII-compliant transceiver in a
single package. It uses a bus master DMA and a scatter/gather descriptor
scheme. The SiS 7016 is similar to the SiS 900 except that it has no
internal PHY, requiring instead an external transceiver to be attached to
its MII interface. The SiS 900 and SiS 7016 both have a 128-bit multi‐
cast hash filter and a single perfect filter entry for the station
The NS DP83815 is also a 100Mbps Ethernet MAC with integrated PHY. The
NatSemi chip and the SiS 900 share many of the same features and a fairly
similar programming interface, hence both chips are supported by the same
The sis driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can
also be used to select either ‘full-duplex’ or ‘half-duplex’
100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8)
mediaopt option can also be used to select either
‘full-duplex’ or ‘half-duplex’ modes.
The sis driver supports the following media options:
full-duplex Force full duplex operation
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The sis driver supports Silicon Integrated Systems SiS 900 and SiS 7016
based Fast Ethernet adapters and embedded controllers, as well as Fast
Ethernet adapters based on the National Semiconductor DP83815 (MacPhyter)
and DP83816 chips. Supported adapters include:
· @Nifty FNECHARD IFC USUP-TX
· MELCO LGY-PCI-TXC
· Netgear FA311-TX (DP83815)
· Netgear FA312-TX (DP83815)
· SiS 630, 635, and 735 motherboard chipsets
· Soekris Engineering net45xx, net48xx, lan1621, and lan1641
The following variable is available as both sysctl(8) variable and
This variable controls how to pad short frames for
DP83815/DP83816 controllers on the specified device.
DP83815/DP83816 controllers are known to pad 0xFF for short
frames which is violation of RFC 1042. Set this variable to a
non-zero value to let driver manually pad each short frame with
zeros at the cost of extra CPU cycles. The default value is 0 to
let hardware perform automatic padding.
sis%d: couldn't map ports/memory A fatal initialization error has
sis%d: couldn't map interrupt A fatal initialization error has occurred.
sis%d: watchdog timeout The device has stopped responding to the net‐
work, or there is a problem with the network connection (e.g. a cable
sis%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
sis%d: no memory for tx list The driver failed to allocate an mbuf for
the transmitter ring when allocating a pad buffer or collapsing an mbuf
chain into a cluster.
sis%d: chip is in D3 power state -- setting to D0 This message applies
only to adapters which support power management. Some operating systems
place the controller in low power mode when shutting down, and some PCI
BIOSes fail to bring the chip out of this state before configuring it.
The controller loses all of its PCI configuration in the D3 state, so if
the BIOS does not set it back to full power mode in time, it will not be
able to configure it correctly. The driver tries to detect this condi‐
tion and bring the adapter back to the D0 (full power) state, but this
may not be enough to return the driver to a fully operational condition.
If you see this message at boot time and the driver fails to attach the
device as a network interface, you will have to perform a warm boot to
have the device properly configured.
Note that this condition only occurs when warm booting from another oper‐
ating system. If you power down your system prior to booting FreeBSD,
the card should be configured correctly.
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), polling(4),
SiS 900 and SiS 7016 datasheets, http://www.sis.com.tw.
NatSemi DP83815 datasheet, http://www.national.com.
The sis device driver first appeared in FreeBSD 3.0.
The sis driver was written by Bill Paul ⟨firstname.lastname@example.org⟩.
BSD September 2, 2010 BSD