IFCONFIG(8) BSD System Manager's Manual IFCONFIG(8)NAMEifconfig — configure network interface parameters
SYNOPSISifconfig interface address_family [address [dest_address]] [parameters]
ifconfig interface [protocol_family]
Ifconfig is used to assign an address to a network interface and/or con‐
figure network interface parameters. Ifconfig must be used at boot time
to define the network address of each interface present on a machine; it
may also be used at a later time to redefine an interface's address or
other operating parameters.
Available operands for ifconfig:
For the DARPA-Internet family, the address is either a host name
present in the host name data base, hosts(5), or a DARPA Internet
address expressed in the Internet standard “dot notation”. For
the Xerox Network Systems(tm) family, addresses are
net:a.b.c.d.e.f, where net is the assigned network number (in
decimal), and each of the six bytes of the host number, a through
f, are specified in hexadecimal. The host number may be omitted
on 10Mb/s Ethernet interfaces, which use the hardware physical
address, and on interfaces other than the first. For the ISO
family, addresses are specified as a long hexadecimal string, as
in the Xerox family. However, two consecutive dots imply a zero
byte, and the dots are optional, if the user wishes to (care‐
fully) count out long strings of digits in network byte order.
Specifies the address family which affects interpretation of the
remaining parameters. Since an interface can receive transmis‐
sions in differing protocols with different naming schemes, spec‐
ifying the address family is recommeded. The address or protocol
families currently supported are “inet”, “iso”, and “ns”.
The interface parameter is a string of the form “name unit”, for
The following parameters may be set with ifconfig:
alias Establish an additional network address for this inter‐
face. This is sometimes useful when changing network
numbers, and one wishes to accept packets addressed to
the old interface.
arp Enable the use of the Address Resolution Protocol in map‐
ping between network level addresses and link level
addresses (default). This is currently implemented for
mapping between DARPA Internet addresses and 10Mb/s Eth‐
-arp Disable the use of the Address Resolution Protocol.
broadcast (Inet only) Specify the address to use to represent
broadcasts to the network. The default broadcast address
is the address with a host part of all 1's.
debug Enable driver dependent debugging code; usually, this
turns on extra console error logging.
-debug Disable driver dependent debugging code.
delete Remove the network address specified. This would be used
if you incorrectly specified an alias, or it was no
longer needed. If you have incorrectly set an NS address
having the side effect of specifying the host portion,
removing all NS addresses will allow you to respecify the
dest_address Specify the address of the correspondent on the other end
of a point to point link.
down Mark an interface ``down''. When an interface is marked
``down'', the system will not attempt to transmit mes‐
sages through that interface. If possible, the interface
will be reset to disable reception as well. This action
does not automatically disable routes using the inter‐
ipdst This is used to specify an Internet host who is willing
to receive ip packets encapsulating NS packets bound for
a remote network. An apparent point to point link is
constructed, and the address specified will be taken as
the NS address and network of the destination. IP encap‐
sulation of CLNP packets is done differently.
metric n Set the routing metric of the interface to n, default 0.
The routing metric is used by the routing protocol
(routed(8)). Higher metrics have the effect of making a
route less favorable; metrics are counted as addition
hops to the destination network or host.
netmask mask (Inet and ISO) Specify how much of the address to reserve
for subdividing networks into sub-networks. The mask
includes the network part of the local address and the
subnet part, which is taken from the host field of the
address. The mask can be specified as a single hexadeci‐
mal number with a leading 0x, with a dot-notation Inter‐
net address, or with a pseudo-network name listed in the
network table networks(5). The mask contains 1's for the
bit positions in the 32-bit address which are to be used
for the network and subnet parts, and 0's for the host
part. The mask should contain at least the standard net‐
work portion, and the subnet field should be contiguous
with the network portion.
nsellength n (ISO only) This specifies a trailing number of bytes for
a received NSAP used for local identification, the
remaining leading part of which is taken to be the NET
(Network Entity Title). The default value is 1, which is
conformant to US GOSIP. When an ISO address is set in an
ifconfig command, it is really the NSAP which is being
specified. For example, in US GOSIP, 20 hex digits
should be specified in the ISO NSAP to be assigned to the
interface. There is some evidence that a number differ‐
ent from 1 may be useful for AFI 37 type addresses.
trailers Request the use of a ``trailer'' link level encapsulation
when sending (default). If a network interface supports
trailers, the system will, when possible, encapsulate
outgoing messages in a manner which minimizes the number
of memory to memory copy operations performed by the
receiver. On networks that support the Address Resolu‐
tion Protocol (see arp(4); currently, only 10 Mb/s Ether‐
net), this flag indicates that the system should request
that other systems use trailers when sending to this
host. Similarly, trailer encapsulations will be sent to
other hosts that have made such requests. Currently used
by Internet protocols only.
-trailers Disable the use of a ``trailer'' link level encapsula‐
link[0-2] Enable special processing of the link level of the inter‐
face. These three options are interface specific in
actual effect, however, they are in general used to
select special modes of operation. An example of this is
to enable SLIP compression. Currently, only used by SLIP.
-link[0-2] Disable special processing at the link level with the
up Mark an interface ``up''. This may be used to enable an
interface after an ``ifconfig down.'' It happens auto‐
matically when setting the first address on an interface.
If the interface was reset when previously marked down,
the hardware will be re-initialized.
Ifconfig displays the current configuration for a network interface when
no optional parameters are supplied. If a protocol family is specified,
Ifconfig will report only the details specific to that protocol family.
Only the super-user may modify the configuration of a network interface.
Messages indicating the specified interface does not exit, the requested
address is unknown, or the user is not privileged and tried to alter an
SEE ALSOnetstat(1), netintro(4), rc(8), routed(8),
The ifconfig command appeared in 4.2BSD.
4.2 Berkeley Distribution June 1, 1994 4.2 Berkeley Distribution