ifmedia man page on MirBSD

Man page or keyword search:  
man Server   6113 pages
apropos Keyword Search (all sections)
Output format
MirBSD logo
[printable version]

IFMEDIA(4)		   BSD Programmer's Manual		    IFMEDIA(4)

NAME
     ifmedia - network interface media settings

SYNOPSIS
     #include <sys/socket.h>
     #include <net/if.h>
     #include <net/if_media.h>

DESCRIPTION
     The ifmedia interface provides a consistent method for querying and set-
     ting network interface media and media options. The media is typically
     set using the ifconfig(8) command.

     There are currently four link types supported by ifmedia:
	   IFM_ETHER	  Ethernet
	   IFM_TOKEN	  Token Ring
	   IFM_FDDI	  FDDI
	   IFM_IEEE80211  IEEE802.11 Wireless LAN

     The following sections describe the possible media settings for each link
     type. Not all of these are supported by every device; refer to your
     device's manual page for more information.

     The lists below provide the possible names of each media type or option.
     The first name in the list is the canonical name of the media type or op-
     tion. Additional names are acceptable aliases for the media type or op-
     tion.

COMMON MEDIA TYPES AND OPTIONS
     The following media types are shared by all link types:
	   IFM_AUTO    Autoselect the best media. [autoselect, auto]
	   IFM_MANUAL  Jumper or switch on device selects media. [manual]
	   IFM_NONE    Deselect all media. [none]

     The following media options are shared by all link types:

	   IFM_FDX    Place the device into full-duplex mode. This option only
		      has meaning if the device is normally not full-duplex.

	   IFM_HDX    Place the device into half-duplex mode. This option only
		      has meaning if the device is normally not half-duplex.
		      [half-duplex, hdx]

	   IFM_FLAG0  Driver-defined flag. [flag0]

	   IFM_FLAG1  Driver-defined flag. [flag1]

	   IFM_FLAG2  Driver-defined flag. [flag2]

	   IFM_LOOP   Place the device into hardware loopback mode. [loopback,
		      hw-loopback, loop]

MEDIA TYPES AND OPTIONS FOR ETHERNET
     The following media types are defined for Ethernet:

	   IFM_10_T	10BASE-T, 10Mb/s over unshielded twisted pair, RJ45
			connector. [10baseT, UTP, 10UTP]

	   IFM_10_2	10BASE2, 10Mb/s over coaxial cable, BNC connector,
			also called Thinnet. [10base2, BNC, 10BNC]

	   IFM_10_5	10BASE5, 10Mb/s over 15-wire cables, DB15 connector,
			also called AUI. [10base5, AUI, 10AUI]

	   IFM_10_STP	10BASE-STP, 10Mb/s over shielded twisted pair, DB9
			connector. [10baseSTP, STP, 10STP]

	   IFM_10_FL	10BASE-FL, 10Mb/s over fiber optic cables. [10baseFL,
			FL, 10FL]

	   IFM_100_TX	100BASE-TX, 100Mb/s over unshielded twisted pair, RJ45
			connector. [100baseTX, 100TX]

	   IFM_100_FX	100BASE-FX, 100Mb/s over fiber optic cables.
			[100baseFX, 100FX]

	   IFM_100_T4	100BASE-T4, 100Mb/s over 4-wire (category 3) unshield-
			ed twisted pair, RJ45 connector. [100baseT4, 100T4]

	   IFM_100_T2	100BASE-T2. [100baseT2, 100T2]

	   IFM_100_VG	100VG-AnyLAN. [100baseVG, 100VG]

	   IFM_1000_SX	1000BASE-SX, 1Gb/s over multi-mode fiber optic cables.
			[1000baseSX, 1000SX]

	   IFM_1000_LX	1000BASE-LX, 1Gb/s over single-mode fiber optic ca-
			bles. [1000baseLX, 1000LX]

	   IFM_1000_CX	1000BASE-CX, 1Gb/s over shielded twisted pair.
			[1000baseCX, 1000CX]

	   IFM_1000_T	1000BASE-T, 1Gb/s over category 5 unshielded twisted
			pair, RJ45 connector. [1000baseT, 1000T]

     The following media option is defined for Ethernet:

	   IFM_ETH_MASTER  Configure a 1000BASE-T PHY as a MASTER PHY.

MEDIA TYPES AND OPTIONS FOR TOKEN RING
     The following media types are defined for Token Ring:

	   IFM_TOK_STP4	  4Mb/s, shielded twisted pair, DB9 connector.
			  [DB9/4Mbit, 4STP]

	   IFM_TOK_STP16  16Mb/s, shielded twisted pair, DB9 connector.
			  [DB9/16Mbit, 16STP]

	   IFM_TOK_UTP4	  4Mb/s, unshielded twisted pair, RJ45 connector.
			  [UTP/4Mbit, 4UTP]

	   IFM_TOK_UTP16  16Mb/s, unshielded twisted pair, RJ45 connector.
			  [UTP/16Mbit, 16UTP]

     The following media options are defined for Token Ring:

	   IFM_TOK_ETR	  Early token release. [EarlyTokenRelease, ETR]

	   IFM_TOK_SRCRT  Enable source routing features. [SourceRouting,
			  SRCRT]

	   IFM_TOK_ALLR	  All routes vs. single route broadcast. [AllRoutes,
			  ALLR]

MEDIA TYPES AND OPTIONS FOR FDDI
     The following media types are defined for FDDI:
	   IFM_FDDI_SMF	 Single-mode fiber. [Single-mode, SMF]
	   IFM_FDDI_MMF	 Multi-mode fiber. [Multi-mode, MMF]
	   IFM_FDDI_UTP	 Unshielded twisted pair, RJ45 connector. [UTP, CDDI]

     The following media options are defined for FDDI:

	   IFM_FDDI_DA	Dual-attached station vs. Single-attached station.
			[dual-attach, das]

MEDIA TYPES AND OPTIONS FOR IEEE802.11 WIRELESS LAN
     The following media types are defined for IEEE802.11 Wireless LAN:
	   IFM_IEEE80211_FH1   Frequency Hopping 1Mbps. [FH1]
	   IFM_IEEE80211_FH2   Frequency Hopping 2Mbps. [FH2]
	   IFM_IEEE80211_DS1   Direct Sequence 1Mbps. [DS1]
	   IFM_IEEE80211_DS2   Direct Sequence 2Mbps. [DS2]
	   IFM_IEEE80211_DS5   Direct Sequence 5.5Mbps. [DS5]
	   IFM_IEEE80211_DS11  Direct Sequence 11Mbps. [DS11]

     The following media options are defined for IEEE802.11 Wireless LAN:
	   IFM_IEEE80211_ADHOC	adhoc mode vs. infrastructure mode [adhoc]
	   IFM_IEEE80211_HOSTAP
				Host Access Point mode, implemented for Prism
				2 and Prism 2.5 chipset, only in wi(4) driver.

SEE ALSO
     netintro(4), ifconfig(8)

HISTORY
     The ifmedia interface first appeared in The implementation that appeared
     in NetBSD 1.3 was written by Jonathan Stone and Jason R. Thorpe to be
     compatible with the BSDI API. It has since gone through several revisions
     which have extended the API while maintaining backwards compatibility
     with the original API.

     Support for the IEEE802.11 Wireless LAN link type was added in
     NetBSD 1.5.

     Host AP mode was added in OpenBSD 3.1.

MirOS BSD #10-current		July 19, 2000				     2
[top]

List of man pages available for MirBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net