inet man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

INET(4)			 BSD Kernel Interfaces Manual		       INET(4)

NAME
     inet — Internet protocol family

SYNOPSIS
     #include <sys/types.h>
     #include <netinet/in.h>

DESCRIPTION
     The Internet protocol family is a collection of protocols layered atop
     the Internet Protocol (IP) transport layer, and utilizing the Internet
     address format.  The Internet family provides protocol support for the
     SOCK_STREAM, SOCK_DGRAM, and SOCK_RAW socket types; the SOCK_RAW inter‐
     face provides access to the IP protocol.

ADDRESSING
     Internet addresses are four byte quantities, stored in network standard
     format (on the VAX these are word and byte reversed).  The include file
     <netinet/in.h> defines this address as a discriminated union.

     Sockets bound to the Internet protocol family utilize the following
     addressing structure,

	   struct sockaddr_in {
		   u_char  sin_len;
		   u_char  sin_family;
		   u_short sin_port;
		   struct  in_addr sin_addr;
		   char	   sin_zero[8];
	   };

     Sockets may be created with the local address INADDR_ANY to affect
     “wildcard” matching on incoming messages.	The address in a connect(2) or
     sendto(2) call may be given as INADDR_ANY to mean “this host”.  The dis‐
     tinguished address INADDR_BROADCAST is allowed as a shorthand for the
     broadcast address on the primary network if the first network configured
     supports broadcast.

PROTOCOLS
     The Internet protocol family is comprised of the IP network protocol,
     Internet Control Message Protocol (ICMP), Internet Group Management Pro‐
     tocol (IGMP), Transmission Control Protocol (TCP), and User Datagram Pro‐
     tocol (UDP).  TCP is used to support the SOCK_STREAM abstraction while
     UDP is used to support the SOCK_DGRAM abstraction.	 A raw interface to IP
     is available by creating an Internet socket of type SOCK_RAW.  The ICMP
     message protocol is accessible from a raw socket.

     The 32-bit Internet address contains both network and host parts.	How‐
     ever, direct examination of addresses is discouraged.  For those programs
     which absolutely need to break addresses into their component parts, the
     following ioctl(2) commands are provided for a datagram socket in the
     Internet domain; they have the same form as the SIOCSIFADDR and
     SIOCGIFADDR commands (see intro(4)).

     SIOCSIFNETMASK  Set interface network mask.  The network mask defines the
		     network part of the address; if it contains more of the
		     address than the address type would indicate, then sub‐
		     nets are in use.

     SIOCGIFNETMASK  Get interface network mask.

ROUTING
     The current implementation of Internet protocols includes some routing-
     table adaptations to provide enhanced caching of certain end-to-end
     information necessary for Transaction TCP and Path MTU Discovery.	The
     following changes are the most significant:

     1.	  All IP routes, except those with the RTF_CLONING flag and those to
	  multicast destinations, have the RTF_PRCLONING flag forcibly enabled
	  (they are thus said to be “protocol cloning”).

     2.	  When the last reference to an IP route is dropped, the route is
	  examined to determine if it was created by cloning such a route.  If
	  this is the case, the RTF_PROTO3 flag is turned on, and the expira‐
	  tion timer is initialized to go off in net.inet.ip.rtexpire seconds.
	  If such a route is re-referenced, the flag and expiration timer are
	  reset.

     3.	  A kernel timeout runs once every ten minutes, or sooner if there are
	  soon-to-expire routes in the kernel routing table, and deletes the
	  expired routes.

     A dynamic process is in place to modify the value of net.inet.ip.rtexpire
     if the number of cached routes grows too large.  If after an expiration
     run there are still more than net.inet.ip.rtmaxcache unreferenced routes
     remaining, the rtexpire value is multiplied by ¾, and any routes which
     have longer expiration times have those times adjusted.  This process is
     damped somewhat by specification of a minimum rtexpire value
     (net.inet.ip.rtminexpire), and by restricting the reduction to once in a
     ten-minute period.

     If some external process deletes the original route from which a proto‐
     col-cloned route was generated, the ``child route'' is deleted.  (This is
     actually a generic mechanism in the routing code support for protocol-
     requested cloning.)

     No attempt is made to manage routes which were not created by protocol
     cloning; these are assumed to be static, under the management of an
     external routing process, or under the management of a link layer (e.g.,
     ARP for Ethernets).

     Only certain types of network activity will result in the cloning of a
     route using this mechanism.  Specifically, those protocols (such as TCP
     and UDP) which themselves cache a long-lasting reference to route for a
     destination will trigger the mechanism; whereas raw IP packets, whether
     locally-generated or forwarded, will not.

   MIB Variables
     A number of variables are implemented in the net.inet branch of the
     sysctl(3) MIB.  In addition to the variables supported by the transport
     protocols (for which the respective manual pages may be consulted), the
     following general variables are defined:

     IPCTL_FORWARDING	   (ip.forwarding) Boolean: enable/disable forwarding
			   of IP packets.  Defaults to off.

     IPCTL_FASTFORWARDING  (ip.fastforwarding) Boolean: enable/disable the use
			   of fast IP forwarding code.	Defaults to off.  When
			   fast forwarding is enabled, IP packets are for‐
			   warded directly to the appropriate network inter‐
			   face with a minimal validity checking, which
			   greatly improves the throughput.  On the other
			   hand, they bypass the standard procedures, such as
			   IP option processing and ipfirewall(4) checking.
			   It is not guaranteed that every packet will be
			   fast-forwarded.

     IPCTL_SENDREDIRECTS   (ip.redirect) Boolean: enable/disable sending of
			   ICMP redirects in response to unforwardable IP
			   packets.  Defaults to on.

     IPCTL_DEFTTL	   (ip.ttl) Integer: default time-to-live (“TTL”) to
			   use for outgoing IP packets.

     IPCTL_SOURCEROUTE	   (ip.sourceroute) Boolean: enable/disable forwarding
			   of source-routed IP packets (default false).

     IPCTL_RTEXPIRE	   (ip.rtexpire) Integer: lifetime in seconds of pro‐
			   tocol-cloned IP routes after the last reference
			   drops (default one hour).  This value varies dynam‐
			   ically as described above.

     IPCTL_RTMINEXPIRE	   (ip.rtminexpire) Integer: minimum value of ip.rtex‐
			   pire (default ten seconds).	This value has no
			   effect on user modifications, but restricts the
			   dynamic adaptation described above.

     IPCTL_RTMAXCACHE	   (ip.rtmaxcache) Integer: trigger level of cached,
			   unreferenced, protocol-cloned routes which initi‐
			   ates dynamic adaptation (default 128).

SEE ALSO
     ioctl(2), socket(2), sysctl(3), icmp(4), intro(4), ip(4), ipfirewall(4),
     tcp(4), udp(4)

     "An Introductory 4.3 BSD Interprocess Communication Tutorial", PS1, 7.

     "An Advanced 4.3 BSD Interprocess Communication Tutorial", PS1, 8.

CAVEAT
     The Internet protocol support is subject to change as the Internet proto‐
     cols develop.  Users should not depend on details of the current imple‐
     mentation, but rather the services exported.

HISTORY
     The inet protocol interface appeared in 4.2BSD.  The “protocol cloning”
     code appeared in FreeBSD 2.1.

BSD			       February 14, 1995			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net