INETD(8) BSD System Manager's Manual INETD(8)NAMEinetd — internet “super-server”
SYNOPSISinetd [-d] [-R rate] [-q queuelength] [configuration file]
DESCRIPTIONinetd should be run at boot time by /etc/init.d/inetd (see init.d(7)).
It then listens for connections on certain internet sockets. When a con‐
nection is found on one of its sockets, it decides what service the
socket corresponds to, and invokes a program to service the request.
After the program is finished, it continues to listen on the socket
(except in some cases which will be described below). Essentially, inetd
allows running one daemon to invoke several others, reducing load on the
The option available for inetd:
-d Turns on debugging.
Specify the maximum number of times a service can be invoked in
one minute; the default is 256.
Sets the size of the socket listen queue to the specified value.
Default is 128.
Print version number and exit.
Print a list with all options and exit.
--help Will give you a list with all options and what they do.
Upon execution, inetd reads its configuration information from a configu‐
ration file which, by default, is /etc/inetd.conf. There must be an
entry for each field of the configuration file, with entries for each
field separated by a tab or a space. Comments are denoted by a “#” at
the beginning of a line. There must be an entry for each field. The
fields of the configuration file are as follows:
user[.group] or user[:group]
server program arguments
To specify a Sun-RPC based service, the entry would contain these fields.
user[.group] or user[:group]
server program arguments
For internet services, the first field of the line may also have a host
address specifier prefixed to it, separated from the service name by a
colon. If this is done, the string before the colon in the first field
indicates what local address inetd should use when listening for that
service. Multiple local addresses can be specified on the same line, sep‐
arated by commas. Numeric IP addresses in dotted-quad notation can be
used as well as symbolic hostnames. Symbolic hostnames are looked up
using gethostbyname(). If a hostname has multiple address mappings,
inetd creates a socket to listen on each address.
The single character “*” indicates INADDR_ANY, meaning “all local
addresses”. To avoid repeating an address that occurs frequently, a line
with a host address specifier and colon, but no further fields, causes
the host address specifier to be remembered and used for all further
lines with no explicit host specifier (until another such line or the end
of the file). A line
is implicitly provided at the top of the file; thus, traditional configu‐
ration files (which have no host address specifiers) will be interpreted
in the traditional manner, with all services listened for on all local
The service-name entry is the name of a valid service in the file
/etc/services. For “internal” services (discussed below), the service
name must be the official name of the service (that is, the first entry
in /etc/services). When used to specify a Sun-RPC based service, this
field is a valid RPC service name in the file /etc/rpc. The part on the
right of the “/” is the RPC version number. This can simply be a single
numeric argument or a range of versions. A range is bounded by the low
version to the high version - “rusers/1-3”.
The socket-type should be one of “stream”, “dgram”, “raw”, “rdm”, or
“seqpacket”, depending on whether the socket is a stream, datagram, raw,
reliably delivered message, or sequenced packet socket.
The protocol must be a valid protocol as given in /etc/protocols. Exam‐
ples might be “tcp” or “udp”. RPC based services are specified with the
“rpc/tcp” or “rpc/udp” service type. “tcp” and “udp” will be recognized
as “TCP or UDP over default IP version”. It is currently IPv4, but in
the future it will be IPv6. If you need to specify IPv4 or IPv6 explic‐
itly, use something like “tcp4” or “udp6”.
The wait/nowait entry is used to tell inetd if it should wait for the
server program to return, or continue processing connections on the
socket. If a datagram server connects to its peer, freeing the socket so
inetd can receive further messages on the socket, it is said to be a
“multi-threaded” server, and should use the “nowait” entry. For datagram
servers which process all incoming datagrams on a socket and eventually
time out, the server is said to be “single-threaded” and should use a
“wait” entry. comsat(8) (biff(1)) and talkd(8) are both examples of the
latter type of datagram server. tftpd(8) is an exception; it is a data‐
gram server that establishes pseudo-connections. It must be listed as
“wait” in order to avoid a race; the server reads the first packet, cre‐
ates a new socket, and then forks and exits to allow inetd to check for
new service requests to spawn new servers. The optional “max” suffix
(separated from “wait” or “nowait” by a dot) specifies the maximum number
of server instances that may be spawned from inetd within an interval of
60 seconds. When omitted, “max” defaults to 40.
Stream servers are usually marked as “nowait” but if a single server
process is to handle multiple connections, it may be marked as “wait”.
The master socket will then be passed as fd 0 to the server, which will
then need to accept the incoming connection. The server should eventu‐
ally time out and exit when no more connections are active. inetd will
continue to listen on the master socket for connections, so the server
should not close it when it exits. identd(8) is usually the only stream
server marked as wait.
The user entry should contain the user name of the user as whom the
server should run. This allows for servers to be given less permission
than root. An optional group name can be specified by appending a dot to
the user name followed by the group name. This allows for servers to run
with a different (primary) group ID than specified in the password file.
If a group is specified and user is not root, the supplementary groups
associated with that user will still be set.
The server-program entry should contain the pathname of the program which
is to be executed by inetd when a request is found on its socket. If
inetd provides this service internally, this entry should be “internal”.
The server program arguments should be just as arguments normally are,
starting with argv, which is the name of the program. If the service
is provided internally, the word “internal” should take the place of this
Meta inetd commands can be specified by starting the line with
“!<command>”. Inetd understands two commands:
Include the contents of the specified file. The file must contain
entries in the same format as /etc/inetd.conf.
Include the output of the specified command.
The script /usr/lib/inetd/includedir can be used to include the entries
of a directory.
inetd provides several “trivial” services internally by use of routines
within itself. These services are “echo”, “discard”, “chargen” (charac‐
ter generator), “daytime” (human readable time), and “time” (machine
readable time, in the form of the number of seconds since midnight, Janu‐
ary 1, 1900). All of these services are TCP based. For details of these
services, consult the appropriate RFC from the Network Information Cen‐
inetd rereads its configuration file when it receives a hangup signal,
SIGHUP. Services may be added, deleted or modified when the configura‐
tion file is reread. inetd creates a file /var/run/inetd.pid that con‐
tains its process identifier.
IPv6 TCP/UDP behavior
If you run servers for IPv4 and IPv6 traffic, you'll need to specify
“tcp4” and “tcp6” properly on the inetd.conf lines. For safety reasons
the author recommends you to run two separate process for the same server
program, specified as two separate lines on inetd.conf, for “tcp6” and
“tcp4”. For detailed description please read on.
The behavior of AF_INET6 socket is documented in RFC2553. Basically, it
says as follows:
· Specific bind on AF_INET6 socket (bind(2) with address specified)
should accept IPv6 traffic to that address only.
· If you perform wildcard bind on AF_INET6 socket (bind(2) to IPv6
address ::), and there is no wildcard bind AF_INET socket on that
TCP/UDP port, IPv6 traffic as well as IPv4 traffic should be routed
to that AF_INET6 socket. IPv4 traffic should be seen as if it came
from IPv6 address like ::ffff:10.1.1.1. This is called IPv4 mapped
· If there are both wildcard bind AF_INET socket and wildcard bind
AF_INET6 socket on one TCP/UDP port, they should behave separately.
IPv4 traffic should be routed to AF_INET socket and IPv6 should be
routed to AF_INET6 socket.
Because of this, inetd will behave as follows.
· If you have only one server on “tcp4”, IPv4 traffic will be routed to
the server. IPv6 traffic will not be accepted.
· If you have two servers on “tcp4” and “tcp6”, IPv4 traffic will be
routed to the server on “tcp4,” and IPv6 traffic will go to server on
“tcp6”. This is not possible in the moment under Linux due kernel
· If you have only one server on “tcp6”, Both IPv4 and IPv6 traffic
will be routed to the server.
The author do not recommend the third option on the above bullets.
RFC2553 does not define the constraint between the order of bind(2), nor
how IPv4 TCP/UDP port number and IPv6 TCP/UDP port number relate each
other (should they be integrated or separated). Implemented behavior is
very different across kernel to kernel. Many of the servers do not prop‐
erly handle IPv4 mapped address. Therefore, it is unwise to rely too
much upon the behavior of AF_INET6 wildcard bind socket.
Host address specifiers, while they make conceptual sense for RPC ser‐
vices, do not work entirely correctly. This is largely because the
portmapper interface does not provide a way to register different ports
for the same service on different local addresses. Provided you never
have more than one entry for a given RPC service, everything should work
correctly. (Note that default host address specifiers do apply to RPC
lines with no explicit specifier.)
“rpc” or “tcpmux” on IPv6 is not tested enough. Kerberos support on IPv6
is not tested.
SEE ALSOcomsat(8), fingerd(8), ftpd(8), rexecd(8), rlogind(8), rshd(8),
The inetd command appeared in 4.3BSD. Support for Sun-RPC based services
is modeled after that provided by SunOS 4.1. IPv6 support and IPsec hack
was made by KAME project, in 1999.
BSD April 13, 2001 BSD