iostat man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

IOSTAT(1M)							    IOSTAT(1M)

NAME
       iostat - report I/O statistics

SYNOPSIS
       /usr/bin/iostat	[-cCdDeEiImMnpPrstxXYz] [-l n] [-T u | d]
	[disk]... [interval [count]]

DESCRIPTION
       The  iostat  utility  iteratively  reports terminal, disk, and tape I/O
       activity, as well as CPU utilization. The first line of output  is  for
       all  time  since	 boot;	each subsequent line is for the prior interval
       only.

       To compute this information, the kernel maintains a number of counters.
       For  each  disk, the kernel counts reads, writes, bytes read, and bytes
       written. The kernel also takes hi-res time stamps at  queue  entry  and
       exit  points,  which  allows it to keep track of the residence time and
       cumulative residence-length product for each queue. Using these values,
       iostat  produces	 highly	 accurate measures of throughput, utilization,
       queue lengths, transaction rates and service time. For  terminals  col‐
       lectively,  the	kernel	simply	counts	the number of input and output
       characters.

       During execution of the kernel status command, the state of the	system
       can  change.  If	 relevant,  a  state change message is included in the
       iostat output, in one of the following forms:

	 <<device added: sd0>>
	 <<device removed: sd0>>
	 <<partition added: sd0,a>>
	 <<partition removed: sd0,a>>
	 <<NFS mounted: nfs1>>
	 <<NFS unmounted: nfs1>>
	 <<multi-path added: ssd4>>
	 <<multi-path removed: ssd4>>
	 <<controller added: c1>>
	 <<controller removed: c1>>
	 <<processors added: 1, 3>>
	 <<processors removed: 1, 3>>

       Note that the names printed in these state change messages are affected
       by the -n and -m options as appropriate.

       For more general system statistics, use sar(1), sar(1M), or vmstat(1M).

   Output
       The output of the iostat utility includes the following information.

       device
		 name of the disk

       r/s
		 reads per second

       w/s
		 writes per second

       kr/s
		 kilobytes read per second

		 The average I/O size during the interval can be computed from
		 kr/s divided by r/s.

       kw/s
		 kilobytes written per second

		 The average I/O size during the interval can be computed from
		 kw/s divided by w/s.

       wait
		 average  number  of  transactions  waiting for service (queue
		 length)

		 This is the number of	I/O  operations	 held  in  the	device
		 driver queue waiting for acceptance by the device.

       actv
		 average   number  of  transactions  actively  being  serviced
		 (removed from the queue but not yet completed)

		 This is the number of I/O operations accepted,	 but  not  yet
		 serviced, by the device.

       svc_t
		 average response time of transactions, in milliseconds

		 The  svc_t  output  reports the overall response time, rather
		 than the service time, of a device. The overall time includes
		 the  time  that  transactions	are in queue and the time that
		 transactions are being serviced.  The time spent in queue  is
		 shown	with  the  -x  option in the wsvc_t output column. The
		 time spent servicing transactions is the true	service	 time.
		 Service  time is also shown with the -x option and appears in
		 the asvc_t output column of the same report.

       %w
		 percent of time there are transactions	 waiting  for  service
		 (queue non-empty)

       %b
		 percent of time the disk is busy (transactions in progress)

       wsvc_t
		 average service time in wait queue, in milliseconds

       asvc_t
		 average service time of active transactions, in milliseconds

OPTIONS
       The following options are supported:

       -c
		   Report  the percentage of time the system has spent in user
		   mode, in system mode, in dtrace probes, and idling. See the
		   NOTES section and mpstat(1m) for more information.

       -C
		   When	 the  -x option is also selected, report extended disk
		   statistics aggregated by controller id.

       -d
		   For each disk, report the number of	kilobytes  transferred
		   per	second,	 the  number  of transfers per second, and the
		   average service time in milliseconds.

       -D
		   For each disk, report the reads per second, writes per sec‐
		   ond, and percentage disk utilization.

       -e
		   Display  device error summary statistics. The total errors,
		   hard errors, soft errors, and  transport  errors  are  dis‐
		   played.

       -E
		   Display all device error statistics.

       -i
		   In  -E  output, display the Device ID instead of the Serial
		   No.	The Device Id is a unique identifier registered	 by  a
		   driver through ddi_devid_register(9F).

       -I
		   Report  the	counts	in  each  interval,  rather than rates
		   (where applicable).

       -l n
		   Limit the number of disks included in the report to n;  the
		   disk	 limit	defaults to 4 for -d and -D, and unlimited for
		   -x. Note: disks explicitly requested (see disk  below)  are
		   not subject to this disk limit.

       -m
		   Report file system mount points. This option is most useful
		   if the -P or -p option is also specified or	used  in  con‐
		   junction  with  -Xn or -en. The -m option is useful only if
		   the mount point is actually	listed	in  the	 output.  This
		   option can only be used in conjunction with the -n option.

       -M
		   Display data throughput in MB/sec instead of KB/sec.

       -n
		   Display  names  in descriptive format. For example, cXtYdZ,
		   rmt/N, server:/export/path.

		   By default, disks are identified by instance names such  as
		   ssd23  or md301. Combining the -n option with the -x option
		   causes disk names to display in the cXtYdZsN	 format	 which
		   is more easily associated with physical hardware character‐
		   istics. The	cXtYdZsN  format  is  particularly  useful  in
		   FibreChannel (FC) environments where the FC World Wide Name
		   appears in the t field.

       -p
		   For each disk, report per-partition statistics in  addition
		   to per-device statistics.

       -P
		   For	each  disk,  report  per-partition statistics only, no
		   per-device statistics.

       -r
		   Display data in a comma-separated format.

       -s
		   Suppress messages related to state changes.

       -t
		   Report the number of characters read and written to	termi‐
		   nals per second.

       -T u | d
		   Display a time stamp.

		   Specify u for a printed representation of the internal rep‐
		   resentation of time. See time(2). Specify  d	 for  standard
		   date format. See date(1).

       -X
		   For	disks under scsi_vhci(7D) control, in addition to disk
		   lun statistics, also report statistics for lun.controller.

       -x
		   Report extended disk	 statistics.  By  default,  disks  are
		   identified  by  instance names such as ssd23 or md301. Com‐
		   bining the x option with the -n option causes disk names to
		   display in the cXtYdZsN format, more easily associated with
		   physical hardware characteristics. Using the cXtYdZsN  for‐
		   mat	is  particularly  helpful in the FibreChannel environ‐
		   ments where the FC World Wide Name appears in the t field.

		   If no output display is requested (no -x, -e,  -E),	-x  is
		   implied.

       -Y
		   For	disks under scsi_vhci(7D) control, in addition to disk
		   lun statistics, also report statistics  for	lun.targetport
		   and lun.targetport.controller.

		   In  -n  (descriptive) mode the targetport is shown in using
		   the target-port property of the path. Without -n  the  tar‐
		   getport  is	shown  using  the  shorter port-id. All target
		   ports with the same target-port property  value  share  the
		   same	 port-id.  The target-port-to-port-id association does
		   not persist across reboot.

		   If no output display is requested (no -x, -e,  -E),	-x  is
		   implied.

       -z
		   Do  not  print  lines  whose underlying data values are all
		   zeros.

       The option set -xcnCXTdz interval is particularly useful for  determin‐
       ing whether disk I/O problems exist and for identifying problems.

OPERANDS
       The following operands are supported:

       count
		   Display only count reports.

       disk
		   Explicitly specify the disks to be reported; in addition to
		   any explicit disks, any active disks up to the  disk	 limit
		   (see -l above) will also be reported.

       interval
		   Report once each interval seconds.

EXAMPLES
       Example 1 Using iostat to Generate User and System Operation Statistics

       The  following  command displays two reports of extended device statis‐
       tics, aggregated by controller id, for user (us) and system (sy) opera‐
       tions.  Because	the  -n option is used with the -x option, devices are
       identified by controller names.

	 example% iostat -xcnCXTdz 5

	 Mon Nov 24 14:58:36 2003
	     cpu
	  us sy dt id
	  14 31	 0 20
			     extended device statistics
	   r/s	  w/s	 kr/s	   kw wait  actv wsvc_t asvc_t	%w  %b device
	   3.8	 29.9	145.8	 44.0  0.0   0.2    0.1	   6.4	 0   5	   c0
	 666.3	814.8 12577.6 17591.1 91.3  82.3   61.6	  55.6	 0   2	  c12
	 180.0	234.6  4401.1  5712.6  0.0 147.7    0.0	 356.3	 0  98	  d10

	 Mon Nov 24 14:58:41 2003
	     cpu
	  us sy dt id
	  11 31	 1 22
			     extended device statistics
	   r/s	  w/s	 kr/s	   kw wait  actv wsvc_t asvc_t	%w  %b device
	   0.8	 41.0	  5.2	 20.5 0.0    0.2    0.2	   4.4	 0   6	   c0
	 565.3	581.7  8573.2 10458.9 0.0   26.6    0.0	  23.2	 0   3	  c12
	 106.5	 81.3  3393.2  1948.6 0.0    5.7    0.0	  30.1	 0  99	  d10

       Example 2 Using iostat to Generate TTY Statistics

       The following command displays two reports  on  the  activity  of  five
       disks  in  different modes of operation. Because the -x option is used,
       disks are identified by instance names.

	 example% iostat -x tc 5 2

			   extended device statistics	     tty	 cpu
	 device r/s  w/s kr/s  kw/s wait actv svc_t %w	%b  tin tout  us sy dt id
	 sd0	0.4  0.3 10.4	8.0  0.0  0.0  36.9  0	 1    0	  10   0  0  0 99
	 sd1	0.0  0.0  0.3	0.4  0.0  0.0  35.0  0	 0
	 sd6	0.0  0.0  0.0	0.0  0.0  0.0	0.0  0	 0
	 nfs1	0.0  0.0  0.0	0.0  0.0  0.0	0.0  0	 0
	 nfs2	0.0  0.0  0.0	0.1  0.0  0.0  35.6  0	 0
		     extended device statistics		     tty	 cpu
	 device r/s  w/s  kr/s	kw/s wait actv svc_t %w	 %b tin tout  us sy dt id
	 sd0	0.0  0.0  0.0	0.0  0.0  0.0  0.0   0	 0   0	155   0	 0  0 100
	 sd1	0.0  0.0  0.0	0.0  0.0  0.0  0.0   0	 0
	 sd6	0.0  0.0  0.0	0.0  0.0  0.0  0.0   0	 0
	 nfs1	0.0  0.0  0.0	0.0  0.0  0.0  0.0   0	 0
	 nfs2	0.0  0.0  0.0	0.0  0.0  0.0  0.0   0	 0

       Example 3 Using iostat to Generate Partition and Device Statistics

       The following command generates partition  and  device  statistics  for
       each disk.  Because the -n option is used with the -x option, disks are
       identified by controller names.

	 example% iostat -xnp

			 extended device statistics
	 r/s  w/s  kr/s kw/s wait actv wsvc_t asvc_t %w %b device
	 0.4  0.3  10.4	 7.9  0.0  0.0	  0.0	36.9  0	 1 c0t0d0
	 0.3  0.3   9.0	 7.3  0.0  0.0	  0.0	37.2  0	 1 c0t0d0s0
	 0.0  0.0   0.1	 0.5  0.0  0.0	  0.0	34.0  0	 0 c0t0d0s1
	 0.0  0.0   0.0	 0.1  0.0  0.0	  0.6	35.0  0	 0 fuji:/export/home/user3

       Example 4 Show Translation from Instance Name to Descriptive Name

       The following example illustrates the use of iostat to translate a spe‐
       cific instance name to a descriptive name.

	 example% iostat -xn sd1
				 extended device statistics
	 r/s	w/s   kr/s   kw/s wait actv wsvc_t asvc_t  %w  %b device
	 0.0	0.0    0.0    0.0  0.0	0.0    0.0    0.0   0	0 c8t1d0

       Example 5 Show Target Port and Controller Activity for a Specific Disk

       In  the following example, there are four controllers, all connected to
       the same target port.

	 # iostat -Y ssd22
			     extended device statistics
	 device		 r/s	w/s   kr/s   kw/s wait actv  svc_t  %w	%b
	 ssd22		 0.2	0.0    1.5    0.0  0.0	0.0    0.7   0	 0
	 ssd22.t2	 0.2	0.0    1.5    0.0  0.0	0.0    0.0   0	 0
	 ssd22.t2.fp0	 0.0	0.0    0.4    0.0  0.0	0.0    0.0   0	 0
	 ssd22.t2.fp1	 0.0	0.0    0.4    0.0  0.0	0.0    0.0   0	 0
	 ssd22.t2.fp2	 0.0	0.0    0.4    0.0  0.0	0.0    0.0   0	 0
	 ssd22.t2.fp3	 0.0	0.0    0.4    0.0  0.0	0.0    0.0   0	 0

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ See below.      │
       └────────────────────┴─────────────────┘

       Invocation is evolving. Human readable output is unstable.

SEE ALSO
       date(1),	  sar(1),   sar(1M),	mpstat(1M),    vmstat(1M),    time(2),
       attributes(5), scsi_vhci(7D)

NOTES
       The  sum	 of  CPU  utilization  might vary slightly from 100 because of
       rounding errors in the production of a percentage figure.

       The svc_t response time is not particularly significant	when  the  I/0
       (r/s+w/s)  rates	 are  under 0.5 per second. Harmless spikes are fairly
       normal in such cases.

       The mpstat utility reports the same dt, usr, and	 sys  statistics.  See
       mpstat(1M) for more information.

       When executed in a zone and if the pools facility is active, iostat(1M)
       will only provide information for those processors in the processor set
       of the pool to which the zone is bound.

				 Mar 23, 2009			    IOSTAT(1M)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net