IPSEC(4) BSD Kernel Interfaces Manual IPSEC(4)NAME
IPsec — Internet Protocol Security protocol
IPsec is a security protocol implemented within the Internet Protocol
layer of the networking stack. IPsec is defined for both IPv4 and IPv6
(inet(4) and inet6(4)). IPsec is a set of protocols, ESP (for Encapsu‐
lating Security Payload) AH (for Authentication Header), and IPComp (for
IP Payload Compression Protocol) that provide security services for IP
datagrams. AH both authenticates and guarantees the integrity of an IP
packet by attaching a cryptographic checksum computed using one-way hash
functions. ESP, in addition, prevents unauthorized parties from reading
the payload of an IP packet by also encrypting it. IPComp tries to
increase communication performance by compressing IP payload, thus reduc‐
ing the amount of data sent. This will help nodes on slow links but with
enough computing power. IPsec operates in one of two modes: transport
mode or tunnel mode. Transport mode is used to protect peer-to-peer com‐
munication between end nodes. Tunnel mode encapsulates IP packets within
other IP packets and is designed for security gateways such as VPN end‐
System configuration requires the crypto(4) subsystem.
The packets can be passed to a virtual enc(4) interface, to perform
packet filtering before outbound encryption and after decapsulation
To properly filter on the inner packets of an IPsec tunnel with fire‐
walls, you can change the values of the following sysctls
Name Default Enable
net.inet.ipsec.filtertunnel 0 1
net.inet6.ipsec6.filtertunnel 0 1
IPsec is controlled by a key management and policy engine, that reside in
the operating system kernel. Key management is the process of associat‐
ing keys with security associations, also know as SAs. Policy management
dictates when new security associations created or destroyed.
The key management engine can be accessed from userland by using PF_KEY
sockets. The PF_KEY socket API is defined in RFC2367.
The policy engine is controlled by an extension to the PF_KEY API,
setsockopt(2) operations, and sysctl(3) interface. The kernel implements
an extended version of the PF_KEY interface and allows the programmer to
define IPsec policies which are similar to the per-packet filters. The
setsockopt(2) interface is used to define per-socket behavior, and
sysctl(3) interface is used to define host-wide default behavior.
The kernel code does not implement a dynamic encryption key exchange pro‐
tocol such as IKE (Internet Key Exchange). Key exchange protocols are
beyond what is necessary in the kernel and should be implemented as dae‐
mon processes which call the APIs.
IPsec policies can be managed in one of two ways, either by configuring
per-socket policies using the setsockopt(2) system calls, or by configur‐
ing kernel level packet filter-based policies using the PF_KEY interface,
via the setkey(8) you can define IPsec policies against packets using
rules similar to packet filtering rules. Refer to setkey(8) on how to
When setting policies using the setkey(8) command, the “default” option
instructs the system to use its default policy, as explained below, for
processing packets. The following sysctl variables are available for
configuring the system's IPsec behavior. The variables can have one of
two values. A 1 means “use”, which means that if there is a security
association then use it but if there is not then the packets are not pro‐
cessed by IPsec. The value 2 is synonymous with “require”, which
requires that a security association must exist for the packets to move,
and not be dropped. These terms are defined in ipsec_set_policy(8).
Name Type Changeable
net.inet.ipsec.esp_trans_deflev integer yes
net.inet.ipsec.esp_net_deflev integer yes
net.inet.ipsec.ah_trans_deflev integer yes
net.inet.ipsec.ah_net_deflev integer yes
net.inet6.ipsec6.esp_trans_deflev integer yes
net.inet6.ipsec6.esp_net_deflev integer yes
net.inet6.ipsec6.ah_trans_deflev integer yes
net.inet6.ipsec6.ah_net_deflev integer yes
If the kernel does not find a matching, system wide, policy then the
default value is applied. The system wide default policy is specified by
the following sysctl(8) variables. 0 means “discard” which asks the ker‐
nel to drop the packet. 1 means “none”.
Name Type Changeable
net.inet.ipsec.def_policy integer yes
net.inet6.ipsec6.def_policy integer yes
Miscellaneous sysctl variables
When the IPsec protocols are configured for use, all protocols are
included in the system. To selectively enable/disable protocols, use
In addition the following variables are accessible via sysctl(8), for
tweaking the kernel's IPsec behavior:
Name Type Changeable
net.inet.ipsec.ah_cleartos integer yes
net.inet.ipsec.ah_offsetmask integer yes
net.inet.ipsec.dfbit integer yes
net.inet.ipsec.ecn integer yes
net.inet.ipsec.debug integer yes
net.inet6.ipsec6.ecn integer yes
net.inet6.ipsec6.debug integer yes
The variables are interpreted as follows:
If set to non-zero, the kernel clears the type-of-service field
in the IPv4 header during AH authentication data computation.
This variable is used to get current systems to inter-operate
with devices that implement RFC1826 AH. It should be set to non-
zero (clear the type-of-service field) for RFC2402 conformance.
During AH authentication data computation, the kernel will
include a 16bit fragment offset field (including flag bits) in
the IPv4 header, after computing logical AND with the variable.
The variable is used for inter-operating with devices that imple‐
ment RFC1826 AH. It should be set to zero (clear the fragment
offset field during computation) for RFC2402 conformance.
This variable configures the kernel behavior on IPv4 IPsec tunnel
encapsulation. If set to 0, the DF bit on the outer IPv4 header
will be cleared while 1 means that the outer DF bit is set
regardless from the inner DF bit and 2 indicates that the DF bit
is copied from the inner header to the outer one. The variable
is supplied to conform to RFC2401 chapter 6.1.
If set to non-zero, IPv4 IPsec tunnel encapsulation/decapsulation
behavior will be friendly to ECN (explicit congestion notifica‐
tion), as documented in draft-ietf-ipsec-ecn-02.txt. gif(4)
talks more about the behavior.
If set to non-zero, debug messages will be generated via
Variables under the net.inet6.ipsec6 tree have similar meanings to those
The IPsec protocol acts as a plug-in to the inet(4) and inet6(4) proto‐
cols and therefore supports most of the protocols defined upon those IP-
layer protocols. The icmp(4) and icmp6(4) protocols may behave differ‐
ently with IPsec because IPsec can prevent icmp(4) or icmp6(4) routines
from looking into the IP payload.
SEE ALSOioctl(2), socket(2), ipsec_set_policy(3), crypto(4), enc(4), icmp6(4),
intro(4), ip6(4), setkey(8), sysctl(8)
S. Kent and R. Atkinson, IP Authentication Header, RFC 2404.
S. Kent and R. Atkinson, IP Encapsulating Security Payload (ESP), RFC
Daniel L. McDonald, Craig Metz, and Bao G. Phan, PF_KEY Key Management
API, Version 2, RFC, 2367.
D. L. McDonald, A Simple IP Security API Extension to BSD Sockets,
internet draft, draft-mcdonald-simple-ipsec-api-03.txt, work in progress
The original IPsec implementation appeared in the WIDE/KAME IPv6/IPsec
For FreeBSD 5.0 a fully locked IPsec implementation called fast_ipsec was
brought in. The protocols drew heavily on the OpenBSD implementation of
the IPsec protocols. The policy management code was derived from the
KAME implementation found in their IPsec protocols. The fast_ipsec
implementation lacked ip6(4) support but made use of the crypto(4) sub‐
For FreeBSD 7.0 ip6(4) support was added to fast_ipsec. After this the
old KAME IPsec implementation was dropped and fast_ipsec became what now
is the only IPsec implementation in FreeBSD.
There is no single standard for the policy engine API, so the policy
engine API described herein is just for this implementation.
AH and tunnel mode encapsulation may not work as you might expect. If
you configure inbound “require” policy with an AH tunnel or any IPsec
encapsulating policy with AH (like “esp/tunnel/A-B/use
ah/transport/A-B/require”), tunnelled packets will be rejected. This is
because the policy check is enforced on the inner packet on reception,
and AH authenticates encapsulating (outer) packet, not the encapsulated
(inner) packet (so for the receiving kernel there is no sign of authen‐
ticity). The issue will be solved when we revamp our policy engine to
keep all the packet decapsulation history.
When a large database of security associations or policies is present in
the kernel the SADB_DUMP and SADB_SPDDUMP operations on PF_KEY sockets
may fail due to lack of space. Increasing the socket buffer size may
alleviate this problem.
The IPcomp protocol may occasionally error because of zlib(3) problems.
This documentation needs more review.
BSD November 29, 2009 BSD