ISP(4) OpenBSD Programmer's Manual ISP(4)NAMEisp - QLogic based SCSI or Fibre Channel SCSI interface
isp* at pci? (PCI)
isp* at sbus? (SBus)
scsibus* at isp?
This driver provides access to a SCSI bus or a Fibre Channel connected to
QLogic ISP1000 (SBus), ISP1020 (PCI), ISP1040 (PCI), ISP1080 (PCI),
ISP12160 (PCI) SCSI host adapters or ISP2100 (PCI/SBus), ISP2200
(PCI/SBus) Fibre Channel or ISP2300 (PCI/SBus) 2-Gigabit Fibre Channel
Features include support for UltraSCSI and wide mode transactions for
SCSI, and Ultra2 LVD (for the ISP1080) and Ultra3 LVD (for the ISP12160)
and the FCP SCSI (private loop, public loop or fabric) for Fibre Channel.
Command tagging is supported for all (in fact, Fibre Channel requires
Adding option ISP_COMPILE_FW to the kernel configuration file ensures
that known good firmware will be downloaded to the driver at attach time.
This is the default setting on sparc, sparc64 and macppc platforms, and
is also recommended on platforms where the card's bios may not be
initialized upon power-up.
SEE ALSOcd(4), ch(4), intro(4), pci(4), sbus(4), scsi(4), sd(4), ses(4), st(4),
The isp driver was written by Matthew Jacob for NASA/Ames Research
OpenBSD 4.9 July 3, 2010 OpenBSD 4.9