KEXTD(8) BSD System Manager's Manual KEXTD(8)NAMEkextd — loads kexts on demand from kernel or client processes
SYNOPSISkextd [-c] [-d] [-f] [-h] [-j] [-r directory] ... [-v [1-6]] [-x]
DESCRIPTIONkextd runs as a daemon process to handle requests from the kernel to load
kernel extensions (kexts). For proper operation kextd must be invoked as
kextd should not be considered a formal interface in the Darwin OS or in
Mac OS X. Neither its usage nor its presence should be relied on by any
software or software installer.
The options available are these:
-c Ignore any repository cache files and scan all kext bundles to
gather information. If this option is not given, kextd will
attempt to use cache files and to create them if they are out of
date or don't exist.
-d Debug mode; run in the foreground without forking as a daemon
-f Don't fork a child task when loading kexts. This option is
present for debugging kextd and should never be used otherwise.
-h Print a help message describing each option flag.
-j Don't jettison kernel linker; load NDRVs in the kernel and exit,
allowing the kernel to continue handling all load requests.
This option is used in startup scripts for install CDs, along
with a properly built mkext cache, in order to speed startup
from the CD.
Use directory as a repository of known kexts for handling load
requests. This is not recursive; only the directory's immediate
contents are scanned. By default kextd uses only the kexts in
Verbose mode; print information about the kext scanning and
loading process (note that this is generally not useful when
unloading). See the man page for kextload(8) to see what each
verbose level prints.
-x Run kextd in safe boot mode (indicating startup with the Shift
key held down). Kexts that don't specify a proper value for the
OSBundleRequired info dictionary property will not be loaded.
This option implies the use of the -c option.
DIAGNOSTICSkextd normally never exits. If an error occurs it exits with a nonzero
status. If invoked with the -j option it exits with a zero status when
no error occurs, or a nonzero status if an error does occur.
kextd logs all error and verbose messages to the system log, or to the
console if the system log facility isn't available. When running in
debug mode all output is printed to the standard output and error
SEE ALSOkextcache(8), kextload(8), kextstat(8), kextunload(8), syslogd(8)Darwin February 14, 2002 Darwin