KLDXREF(8) BSD System Manager's Manual KLDXREF(8)NAMEkldxref — generate hints for the kernel loader
SYNOPSISkldxref [-Rdv] [-f hintsfile] path ...
The kldxref utility is used to generate hint files which list modules,
their version numbers, and the files that contain them. These hints are
used by the kernel loader to determine where to find a particular KLD
A separate hint file is generated for each directory listed on the com‐
mand line that contains modules. If no hint records are generated for a
particular directory, no hint file is created, and the preexisting hint
file (if there was one in that directory) is removed.
The following options are available:
-R Recurse into subdirectories.
-d Do not generate a hint file, but print module metadata on stan‐
Specify a different name for the hints files than linker.hints.
-v Operate in verbose mode.
To build hint files for both standard and add-on modules:
kldxref /boot/kernel /boot/modules
To build hint files for all installed kernels:
SEE ALSOkld(4), kldconfig(8), kldload(8), kldstat(8), kldunload(8)HISTORY
The kldxref utility first appeared in FreeBSD 5.0.
The kldxref utility was implemented by Boris Popov ⟨bp@FreeBSD.org⟩.
This manual page was written by Boris Popov ⟨bp@FreeBSD.org⟩ and
Dag-Erling Smørgrav ⟨des@FreeBSD.org⟩.
BSD October 9, 2001 BSD