kvsnprintf man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

KPRINTF(9)		 BSD Kernel Developer's Manual		    KPRINTF(9)

NAME
     kprintf, ksprintf, ksnprintf, kvprintf, kvsprintf, kvsnprintf,
     krateprintf, tprintf, uprintf, log — formatted output conversion

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     int
     kprintf(const char *format, ...);

     int
     ksprintf(char *str, const char *format, ...);

     int
     ksnprintf(char *str, size_t size, const char *format, ...);

     int
     kvprintf(const char *format, __va_list ap);

     int
     kvsprintf(char *str, const char *format, __va_list ap);

     int
     kvsnprintf(char *str, size_t size, const char *format, __va_list ap);

     void
     krateprintf(struct krate *rate, const char *format, ...);

     int
     tprintf(struct proc *p, int pri, const char *format, ...);

     int
     uprintf(const char *format, ...);

     #include <sys/syslog.h>

     int
     log(int pri, const char *format, ...);

DESCRIPTION
     The kprintf family of functions are similar to the printf(3) family of
     functions.	 The different functions each use a different output stream.
     The uprintf() function outputs to the current process' controlling tty,
     while kprintf(), ksprintf(), ksnprintf(), kvprintf(), kvsprintf() and
     kvsnprintf() write to the console as well as to the logging facility.
     The tprintf() function outputs to the tty associated with the process p
     and the logging facility if pri is not -1.	 The log() function sends the
     message to the kernel logging facility, using the log level as indicated
     by pri.

     Each of these related functions use the format, str, size and va parame‐
     ters in the same manner as printf(3).  However, the kprintf functions add
     two other conversion specifiers to format:

     The %b identifier expects two arguments: an int and a char *.  These are
     used as a register value and a print mask for decoding bitmasks.  The
     print mask is made up of two parts: the base and the arguments.  The base
     value is the output base expressed as an integer value; for example, \10
     gives octal and \20 gives hexadecimal.  The arguments are made up of a
     sequence of bit identifiers.  Each bit identifier begins with an integer
     value which is the number of the bit (starting from 1) this identifier
     describes.	 The rest of the identifier is a string of characters contain‐
     ing the name of the bit.  The string is terminated by either the bit num‐
     ber at the start of the next bit identifier or NUL for the last bit iden‐
     tifier.

     The %D identifier is meant to assist in hexdumps.	It requires two argu‐
     ments: a u_char * pointer and a char * string.  The memory pointed to be
     the pointer is output in hexadecimal one byte at a time.  The string is
     used as a delimiter between individual bytes.  If present, a width direc‐
     tive will specify the number of bytes to display.	By default, 16 bytes
     of data are output.

     The log() function uses syslog(3) level values LOG_DEBUG through
     LOG_EMERG for its pri parameter (mistakenly called ‘priority’ here).
     Alternatively, if a pri of -1 is given, the message will be appended to
     the last log message started by a previous call to log().	As these mes‐
     sages are generated by the kernel itself, the facility will always be
     LOG_KERN.

     The krateprintf() function is a rate controlled version of kprintf().
     The freq member of the struct krate pointed to by rate must be initial‐
     ized with the desired reporting frequency.	 A freq of 0 will result in no
     output.  Initializing count to a negative value allows an initial burst.

RETURN VALUES
     The kprintf(), ksprintf(), ksnprintf(), kvprintf(), kvsprintf(),
     kvsnprintf(), tprintf(), uprintf(), and log() functions return the number
     of characters displayed.

EXAMPLES
     This example demonstrates the use of the %b and %D conversion specifiers.
     The function

	   void
	   kprintf_test(void)
	   {

		   kprintf("reg=%b\n", 3, "\10\2BITTWO\1BITONE\n");
		   kprintf("out: %4D\n", "AAAA", ":");
	   }

     will produce the following output:

	   reg=3<BITTWO,BITONE>
	   out: 41:41:41:41

     The call

	   log(LOG_DEBUG, "%s%d: been there.\n", sc->sc_name, sc->sc_unit);

     will add the appropriate debug message at priority “kern.debug” to the
     system log.

SEE ALSO
     printf(3), syslog(3)

BSD				 July 17, 2008				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net