LOCATE.UPDATEDB(8) BSD System Manager's Manual LOCATE.UPDATEDB(8)NAMElocate.updatedb — update locate database
/usr/libexec/locate.updatedb [---tmpdir=dir] [---fcodes=dbfile]
Locate.updatedb updates the database used by locate(1). It is typically
run once a week by the /etc/weekly script.
The contents of the newly built database can be controlled by the
/etc/locate.rc file as well as the command line arguments.
The available options are as follows:
---tmpdir Sets the directory temporary files are stored in.
---fcodes Use the named file as the find codes database. If the
file name ``-'' is given, the database will be sent to
Sets the list of directories to be put in the database.
---prunepaths Sets the list of parent directories that should not be go
in the database.
A list of filesystem types to be traversed by find(1).
/var/db/locate.database the default database
/etc/locate.rc the configuration file
Woods, James A., "Finding Files Fast", ;login, 8:1, pp. 8-10, 1983.
4.4BSD February 11, 1996 4.4BSD