longjmp man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

SETJMP(9)		 BSD Kernel Developer's Manual		     SETJMP(9)

NAME
     setjmp, longjmp — non-local jumps

SYNOPSIS
     #include <machine/types.h>
     #include <sys/systm.h>

     int
     setjmp(label_t *label);

     void
     longjmp(label_t *label);

DESCRIPTION
     The setjmp() function saves its calling environment in label.  It returns
     zero on success.  The longjmp() function restores the environment saved
     by the most recent invocation of setjmp().	 It returns so that kernel
     execution continues as if the corresponding invocation of the setjmp()
     had just returned.

     setjmp() and longjmp() are a machine-independent interface for machine-
     dependent implementations.

     These functions are primarily used by ddb(4).

SEE ALSO
     ddb(4)

BSD				 May 23, 2002				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net