MAILER.CONF(5) BSD File Formats Manual MAILER.CONF(5)NAMEmailer.conf — configuration file for mailwrapper(8)DESCRIPTION
The file /etc/mail/mailer.conf contains a series of lines of the form
name program [arguments ...]
The first word of each line is the name of a program invoking
mailwrapper(8). (For example, on a typical system /usr/sbin/sendmail
would be a symbolic link to mailwrapper(8), as would newaliases(1) and
mailq(1). Thus, name might be “sendmail” or “newaliases” etc.)
The second word of each line is the name of the program to actually exe‐
cute when the first name is invoked.
The further arguments, if any, are passed to the program, followed by the
arguments mailwrapper(8) was called with.
The file may also contain comment lines, denoted by a ‘#’ mark in the
first column of any line.
This example shows how to set up mailer.conf to invoke the traditional
# Execute the "real" sendmail program located in
This example shows how to invoke a sendmail-workalike like Postfix in
place of sendmail(8):
# Emulate sendmail using postfix
This example shows how to invoke a sendmail-workalike with Exim (from
ports) in place of sendmail(8):
# Emulate sendmail using exim
mailq /usr/local/sbin/exim -bp
rmail /usr/local/sbin/exim -i -oee
This example shows the use of the mini_sendmail package from ports in
place of sendmail(8). Note the use of additional arguments.
# Send outgoing mail to a smart relay using mini_sendmail
sendmail /usr/local/bin/mini_sendmail -srelayhost
send-mail /usr/local/bin/mini_sendmail -srelayhost
SEE ALSOmail(1), mailq(1), newaliases(1), mailwrapper(8), sendmail(8)postfix(1) (ports/mail/postfix), mini_sendmail(8)
HISTORYmailer.conf appeared in NetBSD 1.4.
Perry E. Metzger ⟨firstname.lastname@example.org⟩
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave differ‐
ently if invoked with a different name" behavior of things like mailq(1)
should go away.
BSD November 17, 2010 BSD