make.conf man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

MAKE.CONF(5)		    BSD File Formats Manual		  MAKE.CONF(5)

NAME
     make.conf — system build information

DESCRIPTION
     The file make.conf contains settings that control the compilation of the
     DragonFly sources.	 The file make.conf is generally created by the system
     administrator when the values need to be changed from their defaults.

     The purpose of make.conf is not to run commands or perform compilation
     actions directly.	Instead, it is included by the various makefiles in
     /usr/src which conditionalize their internal actions according to the
     settings found there.

     The /etc/make.conf file is included from the appropriate Makefile which
     specifies the default settings for all the available options.  Options
     need only be specified in /etc/make.conf when the system administrator
     wishes to override these defaults.

     The build procedures occur in three areas: world, kernel, and documenta‐
     tion.  Variables set in make.conf may be applicable during builds in one,
     two, or all of these areas.  They may be specified for a particular build
     via the -D option of make(1).

     The following lists provide a name and short description for each vari‐
     able you can use during the indicated builds.  The values of variables
     flagged as bool are ignored; the variable being set at all (even to
     “FALSE” or “NO”) causes it to be treated as if it were set.

     The following list provides a name and short description for variables
     that are used for all builds, or are used by the makefiles for things
     other than builds.

     CPUTYPE	   (str) Controls which processor should be targeted for gen‐
		   erated code.	 This controls processor-specific optimiza‐
		   tions in certain code (currently only OpenSSL) as well as
		   modifying the value of CFLAGS and COPTFLAGS to contain the
		   appropriate optimization directive to gcc(1).  The auto‐
		   matic setting of CFLAGS and COPTFLAGS may be overridden
		   using the NO_CPU_CFLAGS and NO_CPU_COPTFLAGS variables,
		   respectively.  Refer to
		   /usr/share/examples/etc/defaults/make.conf for a list of
		   recognized CPUTYPE options.

     CCVER	   (str) Controls which GCC version to use by default.	It
		   should be set as CCVER?= so as not to interfere with over‐
		   rides from userland.	 We currently recommend that an over‐
		   ride NOT be set in /etc/make.conf.  Currently accepted val‐
		   ues for compilers which are part of DragonFly are “gcc41”
		   and “gcc44” (default).  All other values will handled
		   according to the settings in compilers.conf(5).

     BINUTILSVER   (str) Controls which binutils to use by default.  Currently
		   accepted values are “binutils220” and “binutils221”
		   (default).

     CFLAGS	   (str) Controls the compiler setting when compiling C code.
		   Optimization levels above -O (-O2, ...) are not supported.
		   BDECFLAGS is provided as a set of gcc(1) settings suggested
		   by Bruce Evans ⟨bde@FreeBSD.org⟩ for developing and testing
		   changes.  They can be used, if set, by:

			 CFLAGS+=${BDECFLAGS}

     DEBUG_FLAGS   (str) Similar to CFLAGS but it will cause STRIP to be set
		   to a blank value, if set.  Typically, DEBUG_FLAGS is set to
		   -g for compiling with debug symbols.

     NO_CPU_CFLAGS
		   (str) Setting this variable will prevent CPU specific com‐
		   piler flags from being automatically added to CFLAGS during
		   compile time.

     CXXFLAGS	   (str) Controls the compiler settings when compiling C++
		   code.  CXXFLAGS is initially set to the value of CFLAGS.
		   If you want to add to the CXXFLAGS value, use “+=” instead
		   of “=”.

     INSTALL	   (str) the default install command.  To have components com‐
		   pared before doing the install, use

			 INSTALL="install -C"

     LOCAL_DIRS	   (str) List any directories that should be entered when run‐
		   ning make /usr/src in this variable.

     MAKE_SHELL	   (str) Controls the shell used internally by make(1) to
		   process the command scripts in makefiles.  sh(1), ksh(1),
		   and csh(1) all currently supported.

			 MAKE_SHELL?=sh

     MODULES_OVERRIDE
		   (str) Set to a list of modules to build instead of all of
		   them.

     MTREE_FOLLOWS_SYMLINKS
		   (str) Set this to “-L” to cause mtree(8) to follow sym‐
		   links.

     STRIP	   (str) Set this to the flag to pass to the strip(1) command.
		   If set to a blank value, debug symbols will not be removed.
		   STRIP is automatically set to a blank value if DEBUG_FLAGS
		   is set.

     WANT_HESIOD   (bool) Set this to build hesiod(3) support into libc.

     NO_NS_CACHING
		   (bool) Set this to disable name caching in the nsswitch
		   subsystem.  The generic caching daemon, nscd(8), will not
		   be built either if this option is set.

     NO_WERROR	   Set this if you don't want -Werror to be added to
		   CWARNFLAGS or used in the kernel build.

     STATIC_LOCALES
		   (str) Set to a list of locales to build into statically-
		   linked binaries.  Currently supported locales are: BIG5 EUC
		   EUCTW ISO2022 MSKanji UTF8

     The following list provides a name and short description for variables
     that are only used doing a kernel build:

     BOOT_COMCONSOLE_PORT
		   (str) The port address to use for the console if the boot
		   blocks have been configured to use a serial console instead
		   of the keyboard/video card.

     BOOT_COMCONSOLE_SPEED
		   (int) The baud rate to use for the console if the boot
		   blocks have been configured to use a serial console instead
		   of the keyboard/video card.

     COPTFLAGS	   (str) Controls the compiler settings when building the ker‐
		   nel.	 Optimization levels above -O (-O2, ...) are not guar‐
		   anteed to work.

     KERNCONF	   (str) Controls which kernel configurations will be built by
		   “${MAKE} buildkernel” and installed by “${MAKE}
		   installkernel”.  For example,

			 KERNCONF=MINE DEBUG GENERIC OTHERMACHINE

		   will build the kernels specified by the config files MINE,
		   DEBUG, GENERIC, and OTHERMACHINE, and install the kernel
		   specified by the config file MINE.  It defaults to GENERIC.

     LOADER_TFTP_SUPPORT
		   (bool) While not a buildkernel-affected option, there is no
		   better place for this.  By default the pxeboot(8) loader
		   retrieves the kernel via NFS.  Defining this and recompil‐
		   ing /usr/src/sys/boot will cause it to retrieve the kernel
		   via TFTP.  This allows pxeboot to load a custom BOOTP disk‐
		   less kernel yet still mount the server's / rather than load
		   the server's kernel.

     NO_CPU_COPTFLAGS
		   (str) Setting this variable will prevent CPU specific com‐
		   piler flags from being automatically added to COPTFLAGS
		   during compile time.

     NO_KERNELCLEAN
		   (bool) Set this to skip the clean target when using
		   “${MAKE} buildkernel”.

     NO_KERNELCONFIG
		   (bool) Set this to skip running config(8) during “${MAKE}
		   buildkernel”.

     NO_KERNELDEPEND
		   (bool) Set this to skip running “${MAKE} depend” during
		   “${MAKE} buildkernel”.

     NO_KERNEL_OLD_STRIP
		   (bool) Set this to skip stripping debugging symbols from
		   old kernel and modules (kernel.old, modules.old) during
		   “${MAKE} installkernel”.

     NO_MODULES	   (bool) Set to not build modules with the kernel.

     The following list provides a name and short description for variables
     that are used during the world build:

     ENABLE_SUID_SSH
		   (bool) Set this to install ssh(1) with the setuid bit
		   turned on.

     MODULES_WITH_WORLD
		   (bool) Set to build modules with the system instead of the
		   kernel.

     NO_CRYPT	   (bool) Set to not build crypto code.

     NO_CVS	   (bool) Set to not build CVS.

     NO_GAMES	   (bool) Set to not build games.

     NO_GCC41	   (bool) Set to not build the older version of GCC (4.1).

     NO_GDB	   (bool) Set to not build gdb(1)

     NO_I4B	   (bool) Set to not build isdn4bsd package.

     NO_IPFILTER   (bool) Set to not build IP Filter package.

     NO_LIBC_R	   (bool) Set to not build libc_r (reentrant version of libc).

     NO_LPR	   (bool) Set to not build lpr(1) and related programs.

     NO_MAILWRAPPER
		   (bool) Set to not build the mailwrapper(8) MTA selector.

     NO_OBJC	   (bool) Set to not build Objective C support.

     NO_OPENSSH	   (bool) Set to not build OpenSSH.

     NO_OPENSSL	   (bool) Set to not build OpenSSL (implies NO_OPENSSH).

     NO_SENDMAIL   (bool) Set to not build sendmail(8) and related programs.

     NO_SHARE	   (bool) Set to not enter the share subdirectory.

     NO_X	   (bool) Set to not compile in X-Windows support (e.g.
		   doscmd(1)).

     NOCLEAN	   (bool) Set this to disable cleaning during “make
		   buildworld”.	 This should not be set unless you know what
		   you are doing.

     NOCLEANDIR	   (bool) Set this to run “${MAKE} clean” instead of “${MAKE}
		   cleandir”.

     NOFSCHG	   (bool) Set to not install certain components with flag
		   schg.  This is useful in a jailed environment.

     NOINFO	   (bool) Set to not make or install info(5) files.

     NOINFOCOMPRESS
		   (bool) Set to not compress the info pages.

     NOMAN	   (bool) Set to not build manual pages

     NOMANCOMPRESS
		   (bool) Set to not compress the manual pages.

     NOPROFILE	   (bool) Set to avoid compiling profiled libraries.

     PPP_NOSUID	   (bool) Set to disable the installation of ppp(8) with the
		   set-user-ID bit on.

     SENDMAIL_MC   (str) The default m4(1) configuration file to use at
		   install time.  The value should include the full path to
		   the .mc file, e.g., /etc/mail/myconfig.mc.  Use with cau‐
		   tion as a make install will overwrite any existing
		   /etc/mail/sendmail.cf.  Note that SENDMAIL_CF is now depre‐
		   cated.

     SENDMAIL_SUBMIT_MC
		   (str) The default m4(1) configuration file for mail submis‐
		   sion to use at install time.	 The value should include the
		   full path to the .mc file, e.g., /etc/mail/mysubmit.mc.
		   Use with caution as a make install will overwrite any
		   existing /etc/mail/submit.cf.

     SENDMAIL_ADDITIONAL_MC
		   (str) Additional .mc files which should be built into .cf
		   files at build time.	 The value should include the full
		   path to the .mc file(s), e.g., /etc/mail/foo.mc
		   /etc/mail/bar.mc.

     SENDMAIL_CF_DIR
		   (str) Override the default location for the m4(1) configu‐
		   ration files used to build a .cf file from a .mc file.

     SENDMAIL_M4_FLAGS
		   (str) Flags passed to m4(1) when building a .cf file from a
		   .mc file.

     SENDMAIL_CFLAGS
		   (str) Flags to pass to the compile command when building
		   sendmail(8).	 The SENDMAIL_* flags can be used to provide
		   SASL support with setting such as:

			 SENDMAIL_CFLAGS=-I/usr/local/include -DSASL
			 SENDMAIL_LDFLAGS=-L/usr/local/lib
			 SENDMAIL_LDADD=-lsasl

     SENDMAIL_LDFLAGS
		   (str) Flags to pass to the ld(1) command when building
		   sendmail(8).

     SENDMAIL_LDADD
		   (str) Flags to add to the end of the ld(1) command when
		   building sendmail(8).

     SENDMAIL_DPADD
		   (str) Extra dependencies to add when building sendmail(8).

     SENDMAIL_SET_USER_ID
		   (bool) If set, install sendmail(8) as a set-user-ID root
		   binary instead of a set-group-ID binary and do not install
		   /etc/mail/submit.{cf,mc}.  Use of this flag is not recom‐
		   mended and the alternative advice in /etc/mail/README
		   should be followed instead if at all possible.

     SENDMAIL_MAP_PERMS
		   (str) Mode to use when generating alias and map database
		   files using /etc/mail/Makefile.  The default value is 0640.

     THREAD_LIB	   (str) Set to either c_r or thread_xu to configure the sys‐
		   tem's default threading library.  The default is thread_xu.

     WANT_IDEA	   (bool) Set to build the IDEA encryption code.  This code is
		   patented in the USA and many European countries.  It is
		   YOUR RESPONSIBILITY to determine if you can legally use
		   IDEA.

     WANT_INSTALLER
		   (bool) Set to build the installer.

     The following list provides a name and short description for variables
     that are used when building documentation.

     DOC_LANG	   (str) The list of languages and encodings to build and
		   install.

     PRINTERDEVICE
		   (str) The default format for system documentation, depends
		   on your printer.  This can be set to “ascii” for simple
		   printers or “ps” for postscript or graphics printers with a
		   ghostscript filter.

     GROFF_PAPER_SIZE
		   (str) The default paper size for groff(1) (either “letter”
		   or “A4”).

FILES
     /etc/defaults/make.conf
     /etc/make.conf
     /usr/src/Makefile
     /usr/src/Makefile.inc1

SEE ALSO
     gcc(1), install(1), make(1), lpd(8), sendmail(8)

HISTORY
     The make.conf file appeared sometime before FreeBSD 4.0.

AUTHORS
     This manual page was written by Mike W. Meyer ⟨mwm@mired.org⟩.

BSD				 April 2, 2011				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net