MAKEDEV(8) BSD System Manager's Manual MAKEDEV(8)NAMEmakedev — make system special files
MAKEDEV device ...
MAKEDEV is a shell script normally used to install special files. It
resides in the /dev directory, as this is the normal location of special
files. Arguments to MAKEDEV are usually of the form device-name? where
device-name is one of the supported devices listed in section 4 of the
manual and “?” is a logical unit number (0-9). A few special arguments
create assorted collections of devices and are listed below.
std Create the standard devices for the system; for example the stan‐
dard UNIX devices /dev/console and /dev/tty; the standard hard‐
ware dependent devices, for example in the VAX family the
VAX-11/780 console floppy device, /dev/floppy, and VAX-11/750 and
VAX-11/730 console cassette device(s), /dev/tu? devices would be
made for the appropriate system.
local Create those devices specific to the local site. This request
causes the shell file /dev/MAKEDEV.local to be executed. Site
specific commands, such as those used to setup dialup lines as
ttyd? should be included in this file.
Since all devices are created using mknod(8), this shell script is useful
only to the super-user.
Either self-explanatory, or generated by one of the programs called from
the script. Use ‘sh -x MAKEDEV’ in case of trouble.
SEE ALSOintro(4), config(8), mknod(8)HISTORY
The makedev command appeared in 4.2BSD.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution