MALO(4) BSD Kernel Interfaces Manual MALO(4)NAMEmalo — Marvell Libertas IEEE 802.11b/g wireless network driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following lines in loader.conf(5):
The malo driver provides support for Marvell Libertas 88W8335 based PCI
and Cardbus network adapters. malo supports station and monitor mode
operation. Only one virtual interface may be configured at any time.
For more information on configuring this device, see ifconfig(8).
This driver requires the malofw firmware kernel module be installed
before it will work. The firmware files are not publicly available. A
port of the firmware can be found at:
The firmware kernel module can be installed by extracting the archive and
running ‘make install clean’ in the malo-firmware-1.4 directory.
The following cards are among those supported by the malo driver:
Card Chip Bus Standard
Netgear WG311v3 88W8335 PCI b/g
Tenda TWL542P 88W8335 PCI b/g
U-Khan UW-2054i 88W8335 PCI b/g
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev malo0 inet 192.168.0.20 \
Join a specific BSS network with network name “my_net”:
ifconfig wlan create wlandev malo0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev malo0 ssid my_net \
wepmode on wepkey 0x1234567890 weptxkey 1 up
SEE ALSOcardbus(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4),
The malo device driver first appeared in FreeBSD 7.1.
BSD October 21, 2009 BSD