MECH(5) BSD File Formats Manual MECH(5)NAME
mech, qop — GSS-API Mechanism and QOP files
The /etc/gss/mech file contains a list of installed GSS-API security
mechanisms. Each line of the file either contains a comment if the first
character is '#' or it contains five fields with the following meanings:
Name The name of this GSS-API mechanism.
The OID for this mechanism.
Library A shared library containing the implementation of this
Kernel module (optional)
A kernel module containing the implementation of this mech‐
anism (not yet supported in FreeBSD).
Library options (optional)
Optional parameters interpreted by the mechanism. Library
options must be enclosed in brackets ([ ]) to differentiate
them from the optional kernel module entry.
The first mechanism listed in /etc/gss/mech is the default mechanism.
This mechanism will be used by gss_init_sec_context(3) if the user
doesn't specify a specific mechanism.
The /etc/gss/qop file contains a list of Quality of Protection values for
use with GSS-API. Each line of the file either contains a comment if the
first character is '#' or it contains three fields with the following
QOP string The name of this Quality of Protection algorithm.
QOP value The numeric value used to select this algorithm for use
with GSS-API functions such as gss_get_mic(3).
The GSS-API mechanism name that corresponds to this algo‐
This is a typical entry from /etc/gss/mech:
kerberosv5 1.2.840.1135126.96.36.199 /usr/lib/libgssapi_krb5.so.8 -
This is a typical entry from /etc/gss/qop:
GSS_KRB5_CONF_C_QOP_DES 0x0100 kerberosv5
The mech manual page first appeared in FreeBSD 7.0.
This manual page was written by Doug Rabson ⟨dfr@FreeBSD.org⟩.
BSD January 26, 2010 BSD