MKNETID(8) BSD System Manager's Manual MKNETID(8)NAMEmknetid — generate netid map data
SYNOPSISmknetid [-q] [-g group_file] [-p passwd_file] [-h hosts_file]
[-n netid_file] [-d domain]
The mknetid utility processes the contents of the group(5), passwd(5),
hosts(5) and netid(5) files into the format used to generate the
netid.byname NIS map. This map is used to hold credential information
for both users and hosts in an operating system independent format.
The mknetid utility checks for duplicate occurrences of netids and fil‐
ters them out.
The mknetid utility prints its results on the standard output. It is
usually called only by /var/yp/Makefile when rebuilding the NIS maps.
The mknetid utility supports the following options:
-q Normally, mknetid prints a warning message when it encounters a
duplicate netid. This flag turns on 'quiet' mode, allowing the
warnings to be suppressed. Other error messages may still be
Specify the location of the group information file. The com‐
piled-in default is /etc/group.
Specify the location of the passwd information file. The com‐
piled-in default is /etc/passwd.
Specify the location of the hosts database file. The compiled-in
default is /etc/hosts.
Specify the location of the netid information file. The com‐
piled-in default is /etc/netid. Note that no error is generated
if the netid database cannot be found. The netid database is not
likely to be present on most systems until Secure RPC support is
added to FreeBSD.
By default, the mknetid utility uses the system domainname when
generating netid records. If the system domainname is not set,
the domain must be specified on the command line with the -d
flag. If the domainname is set, the -d flag may be used to over‐
/var/yp/Makefile the Makefile that calls yp_mkdb and mknetid to build
the NIS databases
/etc/group the default group database file
/etc/passwd the default passwd database file
/etc/hosts the default hosts database file
/etc/netid the default netid database file
SEE ALSOyp(8), yp_mkdb(8)AUTHORS
Bill Paul ⟨firstname.lastname@example.org⟩
BSD June 23, 1996 BSD