mly man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

MLY(4)			 BSD Kernel Interfaces Manual			MLY(4)

NAME
     mly — Mylex AcceleRAID/eXtremeRAID family driver

SYNOPSIS
     To compile this driver into the kernel, place the following lines in your
     kernel configuration file:

	   device pci
	   device scbus
	   device da
	   device mly

     Alternatively, to load the driver as a module at boot time, place the
     following line in loader.conf(5):

	   mly_load="YES"

DESCRIPTION
     The mly driver provides support for Mylex AcceleRAID and eXtremeRAID-fam‐
     ily PCI to SCSI RAID controllers with version 6.00 and later firmware.

     Logical devices (array drives) attached to the controller are presented
     to the SCSI subsystem as though they were direct-access devices on a vir‐
     tual SCSI bus.  Physical devices which are not claimed by a logical
     device are presented on SCSI channels which match the physical channels
     on the controller.

HARDWARE
     Controllers supported by the mly driver include:

     ·	 Mylex AcceleRAID 160
     ·	 Mylex AcceleRAID 170
     ·	 Mylex AcceleRAID 352
     ·	 Mylex eXtremeRAID 2000
     ·	 Mylex eXtremeRAID 3000

     Compatible Mylex controllers not listed should work, but have not been
     verified.

DIAGNOSTICS
   Controller initialisation phase
     mly%d: controller initialisation started
     mly%d: initialisation complete

     The controller firmware has started initialisation.  Normally this
     process is performed by the controller BIOS, but the driver may need to
     do this in cases where the BIOS has failed, or is not compatible (e.g. on
     non-x86 systems).

     mly%d: drive spinup in progress

     Drive startup is in progress; this may take several minutes.

     mly%d: mirror race recovery failed, one or more drives offline
     mly%d: mirror race recovery in progress
     mly%d: mirror race recovery on a critical drive

     These error codes are undocumented.

     mly%d: FATAL MEMORY PARITY ERROR

     Firmware detected a fatal memory error; the driver will not attempt to
     attach to this controller.

     mly%d: unknown initialisation code %x

     An unknown error occurred during initialisation; it will be ignored.

   Driver initialisation/shutdown phase
     mly%d: can't enable busmaster feature
     mly%d: memory window not available
     mly%d: can't allocate register window
     mly%d: can't allocate interrupt
     mly%d: can't set up interrupt

     The system's PCI BIOS has not correctly configured the controller's PCI
     interface; initialisation has failed and the driver will not attach to
     this controller.

     mly%d: can't allocate parent DMA tag
     mly%d: can't allocate buffer DMA tag
     mly%d: can't allocate command packet DMA tag
     mly%d: can't allocate scatter/gather DMA tag
     mly%d: can't allocate s/g table
     mly%d: can't allocate memory mailbox DMA tag
     mly%d: can't allocate memory mailbox

     A resource allocation error occurred while initialising the driver; ini‐
     tialisation has failed and the driver will not attach to this controller.

     mly%d: BTL rescan result corrupted

     The results of a scan for an attached device were corrupted.  One or more
     devices may not be correctly reported.

     mly%d: flushing cache...

     The controller cache is being flushed prior to detach or shutdown.

   Operational diagnostics
     mly%d: physical device %d:%d online
     mly%d: physical device %d:%d standby
     mly%d: physical device %d:%d automatic rebuild started
     mly%d: physical device %d:%d manual rebuild started
     mly%d: physical device %d:%d rebuild completed
     mly%d: physical device %d:%d rebuild cancelled
     mly%d: physical device %d:%d rebuild failed for unknown reasons
     mly%d: physical device %d:%d rebuild failed due to new physical device
     mly%d: physical device %d:%d rebuild failed due to logical drive failure
     mly%d: physical device %d:%d found
     mly%d: physical device %d:%d gone
     mly%d: physical device %d:%d unconfigured
     mly%d: physical device %d:%d expand capacity started
     mly%d: physical device %d:%d expand capacity completed
     mly%d: physical device %d:%d expand capacity failed
     mly%d: physical device %d:%d parity error
     mly%d: physical device %d:%d soft error
     mly%d: physical device %d:%d miscellaneous error
     mly%d: physical device %d:%d reset
     mly%d: physical device %d:%d active spare found
     mly%d: physical device %d:%d warm spare found
     mly%d: physical device %d:%d initialization started
     mly%d: physical device %d:%d initialization completed
     mly%d: physical device %d:%d initialization failed
     mly%d: physical device %d:%d initialization cancelled
     mly%d: physical device %d:%d write recovery failed
     mly%d: physical device %d:%d scsi bus reset failed
     mly%d: physical device %d:%d double check condition
     mly%d: physical device %d:%d device cannot be accessed
     mly%d: physical device %d:%d gross error on scsi processor
     mly%d: physical device %d:%d bad tag from device
     mly%d: physical device %d:%d command timeout
     mly%d: physical device %d:%d system reset
     mly%d: physical device %d:%d busy status or parity error
     mly%d: physical device %d:%d host set device to failed state
     mly%d: physical device %d:%d selection timeout
     mly%d: physical device %d:%d scsi bus phase error
     mly%d: physical device %d:%d device returned unknown status
     mly%d: physical device %d:%d device not ready
     mly%d: physical device %d:%d device not found at startup
     mly%d: physical device %d:%d COD write operation failed
     mly%d: physical device %d:%d BDT write operation failed
     mly%d: physical device %d:%d missing at startup
     mly%d: physical device %d:%d start rebuild failed due to physical drive
     too small
     mly%d: physical device %d:%d sense data received
     mly%d:   sense key %d  asc %02x  ascq %02x
     mly%d:   info %4D	csi %4D
     mly%d: physical device %d:%d offline
     mly%d:   sense key %d  asc %02x  ascq %02x
     mly%d:   info %4D	csi %4D

     The reported event refers to the physical device at the given chan‐
     nel:target address.

     mly%d: logical device %d (%s) consistency check started
     mly%d: logical device %d (%s) consistency check completed
     mly%d: logical device %d (%s) consistency check cancelled
     mly%d: logical device %d (%s) consistency check completed with errors
     mly%d: logical device %d (%s) consistency check failed due to logical
     drive failure
     mly%d: logical device %d (%s) consistency check failed due to physical
     device failure
     mly%d: logical device %d (%s) automatic rebuild started
     mly%d: logical device %d (%s) manual rebuild started
     mly%d: logical device %d (%s) rebuild completed
     mly%d: logical device %d (%s) rebuild cancelled
     mly%d: logical device %d (%s) rebuild failed for unknown reasons
     mly%d: logical device %d (%s) rebuild failed due to new physical device
     mly%d: logical device %d (%s) rebuild failed due to logical drive
     failure
     mly%d: logical device %d (%s) offline
     mly%d: logical device %d (%s) critical
     mly%d: logical device %d (%s) online
     mly%d: logical device %d (%s) initialization started
     mly%d: logical device %d (%s) initialization completed
     mly%d: logical device %d (%s) initialization cancelled
     mly%d: logical device %d (%s) initialization failed
     mly%d: logical device %d (%s) found
     mly%d: logical device %d (%s) gone
     mly%d: logical device %d (%s) expand capacity started
     mly%d: logical device %d (%s) expand capacity completed
     mly%d: logical device %d (%s) expand capacity failed
     mly%d: logical device %d (%s) bad block found
     mly%d: logical device %d (%s) size changed
     mly%d: logical device %d (%s) type changed
     mly%d: logical device %d (%s) bad data block found
     mly%d: logical device %d (%s) read of data block in bdt
     mly%d: logical device %d (%s) write back data for disk block lost

     The event report will include the name of the SCSI device which has
     attached to the device if possible.

     mly%d: enclosure %d fan %d failed
     mly%d: enclosure %d fan %d ok
     mly%d: enclosure %d fan %d not present
     mly%d: enclosure %d power supply %d failed
     mly%d: enclosure %d power supply %d ok
     mly%d: enclosure %d power supply %d not present
     mly%d: enclosure %d temperature sensor %d failed
     mly%d: enclosure %d temperature sensor %d critical
     mly%d: enclosure %d temperature sensor %d ok
     mly%d: enclosure %d temperature sensor %d not present
     mly%d: enclosure %d unit %d access critical
     mly%d: enclosure %d unit %d access ok
     mly%d: enclosure %d unit %d access offline

     These events refer to external enclosures by number.  The driver does not
     attempt to name the enclosures.

     mly%d: controller cache write back error
     mly%d: controller battery backup unit found
     mly%d: controller battery backup unit charge level low
     mly%d: controller battery backup unit charge level ok
     mly%d: controller installation aborted
     mly%d: controller mirror race recovery in progress
     mly%d: controller mirror race on critical drive
     mly%d: controller memory soft ecc error
     mly%d: controller memory hard ecc error
     mly%d: controller battery backup unit failed

     These events report controller status changes.

AUTHORS
     The mly driver was written by Michael Smith ⟨msmith@FreeBSD.org⟩.

     This manual page was written by Michael Smith ⟨msmith@FreeBSD.org⟩.

BUGS
     The driver does not yet provide an external management interface.

     Enclosures are not named or otherwise identified in event messages.

BSD				August 10, 2004				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net