MOUNT_NTFS(8) BSD System Manager's Manual MOUNT_NTFS(8)NAMEmount_ntfs — mount an NTFS file system
SYNOPSISmount_ntfs [-a] [-i] [-u user] [-g group] [-m mask] [-C charset]
[-W u2wtable] special node
The mount_ntfs utility attaches the NTFS file system residing on the
device special to the global file system namespace at the location indi‐
cated by node. This command is normally executed by mount(8) at boot
time, but can be used by any user to mount an NTFS file system on any
directory that they own (provided, of course, that they have appropriate
access to the device that contains the file system).
The options are as follows:
-a Force behaviour to return MS-DOS 8.3 names also on readdir().
-i Make name lookup case insensitive for all names except POSIX
Set the owner of the files in the file system to user. The
default owner is the owner of the directory on which the file
system is being mounted.
Set the group of the files in the file system to group. The
default group is the group of the directory on which the file
system is being mounted.
Specify the maximum file permissions for files in the file sys‐
tem. Only the nine low-order bits of mask are used.
Specify local charset to convert Unicode file names. Currently
only reading is supported, thus the file system is to be mounted
Specify UNIX to Unicode translation table. See mount_msdosfs(8)
for the description of this option. This option is preserved for
backward compatibility purpose only, and will be removed in the
future. Please do not use this option.
NTFS file attributes are accessed in following way:
‘ATTRTYPE’ is one of the identifiers listed in $AttrDef file of volume.
Default is $DATA. ‘ATTRNAME’ is an attribute name. Default is none.
To mount an NTFS volume located in /dev/ad1s1:
mount_ntfs /dev/ad1s1 /mnt
To get the volume name (in Unicode):
To read directory raw data:
To mount a Japanese NTFS volume located in /dev/ad0s1:
mount_ntfs-C eucJP /dev/ad0s1 /mnt
There is limited writing ability. Limitations: file must be nonresident
and must not contain any sparces (uninitialized areas); compressed files
are also not supported. The file name must not contain multibyte charac‐
SEE ALSOmount(2), unmount(2), fstab(5), mount(8), mount_msdosfs(8)CAVEATS
This utility is primarily used for read access to an NTFS volume. See
the WRITING section for details about writing to an NTFS volume.
For a full read-write NTFS support consider sysutils/fusefs-ntfs
The mount_ntfs utility first appeared in FreeBSD 3.0.
The Unicode conversion routine was added by Ryuichiro Imura
⟨firstname.lastname@example.org⟩ in 2003.
The NTFS kernel implementation, mount_ntfs utility, and manual were writ‐
ten by Semen Ustimenko ⟨semenu@FreeBSD.org⟩.
BSD November 17, 2007 BSD