MOUNT_SMBFS(8) BSD System Manager's Manual MOUNT_SMBFS(8)NAMEmount_smbfs — mount a shared resource from an SMB file server
SYNOPSISmount_smbfs [-E cs1:cs2] [-I host] [-L locale] [-M crights:srights] [-N]
[-O cowner:cgroup/sowner:sgroup] [-R retrycount] [-T timeout]
[-U username] [-W workgroup] [-c case] [-d mode] [-f mode]
[-g gid] [-n opt] [-u uid]
The mount_smbfs command mounts a share from a remote server using
The options are as follows:
Specifies local (cs1) and server's (cs2) character sets.
Do not use NetBIOS name resolver and connect directly to host,
which can be either a valid DNS name or an IP address.
Use locale for lower/upper case conversion routines. Set the
locale for case conversion. By default, mount_smbfs tries to use
an environment variable LC_* to determine it.
Assign access rights to the newly created connection.
-N Do not ask for a password. At run time, mount_smbfs reads the
~/.nsmbrc file for additional configuration parameters and a
password. If no password is found, mount_smbfs prompts for it.
Assign owner/group attributes to the newly created connection.
How many retries should be done before the SMB requester decides
to drop the connection. Default is 4.
Timeout in seconds for each request. Default is 15.
Username to authenticate with.
This option specifies the workgroup to be used in the authentica‐
Set a case option which affects name representation. case can be
one of the following:
l All existing file names are converted to lower case.
Newly created file gets a lower case.
u All existing file names are converted to upper case.
Newly created file gets an upper case.
-f mode, -d mode
Specify permissions that should be assigned to files and directo‐
ries. The values must be specified as octal numbers. Default
value for the file mode is taken from mount point, default value
for the directory mode adds execute permission where the file
mode gives read permission.
Note that these permissions can differ from the rights granted by
-u uid, -g gid
User ID and group ID assigned to files. The default are owner
and group IDs from the directory where the volume is mounted.
The mount_smbfs command will use server as the NetBIOS name of
remote computer, user as the remote user name and share as the
resource name on a remote server. Optional port1 and port2 argu‐
ments can be used to override default values of port numbers used
by communication protocols. For SMB over NetBIOS default value
for port1 are 139, and port2 are 137.
node Path to mount point.
~/.nsmbrc Keeps static parameters for connections and other information.
See /usr/share/examples/smbfs/dot.nsmbrc for details.
The following example illustrates how to connect to SMB server SAMBA as
user GUEST, and mount shares PUBLIC and TMP:
mount_smbfs-I samba.mydomain.com //guest@samba/public /smb/public
mount_smbfs-I 192.168.20.3 -E koi8-r:cp866 //guest@samba/tmp /smb/tmp
It is possible to use fstab(5) for smbfs mounts:
//guest@samba/public /smb/public smbfs rw,noauto 0 0
Boris Popov ⟨firstname.lastname@example.org⟩, ⟨bp@FreeBSD.org⟩
Please report bugs to the author.
BSD January 21, 2008 BSD