MOUNT_SMBFS(8) BSD System Manager's Manual MOUNT_SMBFS(8)NAMEmount_smbfs — mounts a shared resource from an SMB file server
SYNOPSISmount_smbfs [-I host] [-M cmode[/smode]] [-N]
[-O cowner[:cgroup]/sowner[:sgroup]] [-R retrycount]
[-T timeout] [-U user] [-W workgroup] [-d mode] [-f mode]
[-g gid] [-h] [-n opt] [-u uid] //[workgroup;][user[
password]@] server[/share] path
The mount_smbfs command mounts a share from a remote server using
The options are:
Do not use NetBIOS name resolver and connect directly to host,
which can be either a valid DNS name or an IP address.
Assign access rights to the newly created connection.
-N Do not ask for a password. At run time, mount_smbfs reads the
~/.nsmbrc file for additional configuration parameters and a
password. If no password is found the mount_smbfs prompts for
Assign owner/group attributes to the newly created connection.
How many retries should be done before the SMB requester decides
to drop the connection.
Timeout in seconds for each request.
Specifies the user name to be used in the authentication request.
Specifies the workgroup to be used in the authentication request.
-f mode, -d mode
Specify permissions that should be assigned to files and directo‐
ries. The values must be specified as octal numbers. Default
value for the file mode is taken from mount point, default value
for the dir mode adds execute permission where the file mode
gives read permission.
Note that these permissions can differ from the rights granted by
-h Prints a help message, much like the SYNOPSIS above.
-n opt Set opt option to affect file name lookups. opt can be one of
long No long names. Server supports only "8.3" format.
-u uid, -g gid
User id and group id assigned to files. The default is owner and
group id from directory where the volume is mounted.
The mount_smbfs command will use server as the NetBIOS name of
remote computer, user as the remote user name and share as the
resource name on a remote server. Workgroup and/or password may
be specified here. If user is omitted the logged in user id will
be used. Omitting share is an error when mount_smbfs is run from
the command line, otherwise a browsing dialogue is presented.
path Path to mount point.
~/.nsmbrc Keeps static parameters for connections and other informa‐
tion. See ./examples/dot.nsmbrc for details.
The following illustrate how to connect to an SMB server SAMBA as user
GUEST to mount PUBLIC:
mount_smbfs-I samba.mydomain.com //guest@samba/public /smb/public
Please report bugs to Apple.
Boris Popov ⟨email@example.com⟩, ⟨firstname.lastname@example.org⟩
FreeBSD Mar 10, 2000 FreeBSD