mstohz man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

MSTOHZ(9)		 BSD Kernel Developer's Manual		     MSTOHZ(9)

NAME
     mstohz, hztoms — convert between milliseconds and system clock ticks

SYNOPSIS
     #include <sys/param.h>

     int
     mstohz(int ms);

     int
     hztoms(int hz);

DESCRIPTION
     The mstohz() macro can be used to convert time in milliseconds to system
     clock ticks, as used by the callout(9) facility, in an integer-overflow
     safe way.	Conversely, hztoms() converts system clock ticks to millisec‐
     onds.

     These macros are defined in the ⟨sys/param.h⟩ header.  Individual ports
     can have a processor-specific, more efficient version implemented in
     their ⟨machine/param.h⟩ header as a define.

RETURN VALUES
     The return value is either the number of clock ticks or milliseconds for
     the specified value.

SEE ALSO
     param(3), callout(9), tvtohz(9)

BUGS
     Neither mstohz() nor hztoms() make use of expensive 64-bit integer arith‐
     metic.  The result from mstohz() will be rounded down to one second if
     the parameter is larger than 131072 milliseconds.

BSD			       October 20, 2011				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net