net_protocol_walk man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_PROTOCOL_WALK(9F)					 NET_PROTOCOL_WALK(9F)

NAME
       net_protocol_walk  - step through the list of registered network proto‐
       cols

SYNOPSIS
       #include <sys/neti.h>

       net_data_t *net_protocol_walk(net_data_t net);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
	      value  returned	from   a   successful	call   to   net_proto‐
	      col_lookup(9F).

DESCRIPTION
       The  net_protocol_walk() function walks through all of the network pro‐
       tocols that have been registered with this interface. The initial  call
       to  net_protocol_walk()	should be made by passing in NULL as the value
       for net. When this function returns NULL, the end of the list has  been
       reached.

       A  caller of net_protocol_walk() is required to walk through the entire
       list of network protocols, until NULL is	 returned  or,	when  finished
       with  using  the	 value	returned,  pass	 it  into a call to net_proto‐
       col_release(9F).

RETURN VALUES
       The net_protocol_walk() function returns NULL when the end of the  list
       is  returned.  Otherwise,  it  returns  a non-NULL value as a token for
       being passed into other function calls within this interface.

CONTEXT
       The net_protocol_walk() function may be called from user,   kernel,  or
       interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_protocol_lookup(9F), net_protocol_release(9F), attributes(5)

				  May 1, 2008		 NET_PROTOCOL_WALK(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net