NEWKEY(8) BSD System Manager's Manual NEWKEY(8)NAMEnewkey — create a new key in the publickey database
The newkey utility is normally run by the network administrator on the
Network Interface Service (NIS) master machine in order to establish pub‐
lic keys for users and super-users on the network. These keys are needed
for using secure RPC or secure NFS.
The newkey utility will prompt for the login password of the given user‐
name and then create a new public/secret key pair in /etc/publickey
encrypted with the login password of the given user.
Use of this program is not required: users may create their own keys
Create a new public key for the super-user at the given hostname.
Prompts for the root password of the given hostname.
Create a new public key for the given username. Prompts for the
NIS password of the given username.
SEE ALSOchkey(1), keylogin(1), publickey(5), keyserv(8)NOTES
The Network Information Service (NIS) was formerly known as Sun Yellow
Pages (YP). The functionality of the two remains the same; only the name
BSD October 12, 1987 BSD