newkey(1M)newkey(1M)NAMEnewkey - create a new Diffie-Hellman key pair in the publickey database
establishes new public keys for users and machines on the network.
These keys are needed when using secure RPC or secure NFS service.
prompts for a password for the given username or hostname and then cre‐
ates a new public/secret Diffie-Hellman 192 bit key pair for the user
or host. The secret key is encrypted with the given password. The key
pair can be stored in the file, the NIS map, or entries in the LDAP
consults the entry in the name service switch configuration file (see
nsswitch.conf(4)) to determine which naming service is used to store
the secure RPC keys. If the entry specifies a unique name service,
will add the key in the specified name service. However, if there are
multiple name services listed, cannot decide which source to update and
will display an error message. The user is required to specify the
source explicitly with the option.
In the case of NIS, should be run by the superuser on the master NIS
server for that domain. In the case of LDAP, should be run by the
superuser on a machine that has permission to update the entries in the
Create a new public/secret key pair for the privileged user at
hostname. Prompts for a password for the given
Create a new public/secret key pair for the given
username. Prompts for a password for the given
Update the database in the specified source:
(for NIS), or (LDAP). Other sources may be
available in the future.
HP-UX 11i Version 2 is the last HP-UX release on which NIS+ is sup‐
ported. LDAP is the recommended replacement for NIS+. HP fully sup‐
ports the industry standard naming services based on LDAP.
was developed by Sun Microsystems, Inc.
SEE ALSOchkey(1), keylogin(1), nsswitch.conf(4), publickey(4).