NFSD(8) BSD System Manager's Manual NFSD(8)NAMEnfsd — remote NFS server
SYNOPSISnfsd [-rut] [-n num_servers]
Nfsd runs on a server machine to service NFS requests from client
machines. At least one nfsd must be running for a machine to operate as
Unless otherwise specified, four servers for UDP transport are started.
The following options are available:
-r Register the NFS service with portmap(8) without creating any
servers. This option can be used along with the -u or -t options
to re-register NFS if the portmap server is restarted.
-n Specifies how many servers to create.
-t Serve TCP NFS clients.
-u Serve UDP NFS clients.
For example, “nfsd -u -t 6” serves UDP and TCP transports using six dae‐
A server should run enough daemons to handle the maximum level of concur‐
rency from its clients, typically four to six.
Nfsd listens for service requests at the port indicated in the NFS server
specification; see Network File System Protocol Specification, RFC1094
and NFS: Network File System Version 3 Protocol Specification.
The nfsd utility exits 0 on success, and >0 if an error occurs.
SEE ALSOnfsstat(1), nfssvc(2), mountd(8), portmap(8)HISTORY
The nfsd utility first appeared in 4.4BSD.
BSD March 29, 1995 BSD