NG_DEVICE(4) BSD Kernel Interfaces Manual NG_DEVICE(4)NAMEng_device — device netgraph node type
A device node is both a netgraph node and a system device interface.
When a device node is created, a new device entry appears which is acces‐
sible via the regular file operators such as open(2), close(2), read(2),
The first node is created as /dev/ngd0, all subsequent nodes /dev/ngd1,
A device node has a single hook with an arbitrary name. All data coming
in over the hook will be presented to the device for read(2). All data
coming in from the device entry by write(2) will be forwarded to the
The device node supports one non-generic control message:
Returns device name corresponding to a node.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
upon hook disconnection. The associated device entry is removed and
becomes available for use by future device nodes.
SEE ALSOnetgraph(4), ngctl(8)HISTORY
The device node type was first implemented in FreeBSD 5.0.
Mark Santcroos ⟨firstname.lastname@example.org⟩
Gleb Smirnoff ⟨glebius@FreeBSD.org⟩
BSD October 19, 2004 BSD