NG_ETHER_ECHO(4) BSD Kernel Interfaces Manual NG_ETHER_ECHO(4)NAMEng_ether_echo — netgraph ether_echo node type
The ether_echo node type reflects all data and control messages back to
the sender. It assumes (and does not check) that the packet is an ether‐
net frame, and swaps the source and destination addresses before echoing
it. This node type is used for testing and debugging.
A ether_echo node accepts any request to connect, regardless of the hook
name, as long as the name is unique.
This node type supports only the generic control messages. Any other
control messages are reflected back to the sender.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
SEE ALSOnetgraph(4), ng_hole(4), ng_echo(4), ng_ether(4), ngctl(8)HISTORY
The ng_ether_echo node type was implemented in FreeBSD 8.0.
Julian Elischer ⟨julian@FreeBSD.org⟩
BSD December 24, 2008 BSD